I've recently switched to Ubuntu, and the one thing that has been bothering me is the scroll speed, which I can't seem to change. In windows I used to have it set around 7 lines, but it seem to be around 3 on Ubuntu, and unchangeable. How can I change the speed?

up vote 23 down vote accepted

If it's only for web, you can change the scroll speed in FireFox:

  • Edit menu > Preferences > Advanced tab > Browsing group: disable smooth scrolling

Fine-tuning:

  • Type enter about:config in the address bar
  • Find and change mousewheel.withnokey.sysnumlines to FALSE
  • Then change the mousewheel.withnokey.numlines from 1 to whatever you want.

And a more general, system-wide solution:

  • 2
    For the whole system. – Kironide Feb 20 '11 at 16:34
  • 5
    Just unplug and plug again the mouse connector. It worked for me. – Airton Sobral May 10 '12 at 19:34
  • 3
    Yes. It did worked for me too. I was using a wireless mouse. First I tried to switch off & on the mouse power, but that didnt help. Then I unplugged the usb adapter, waited for a few seconds and then plugged in again. – user81089 Aug 3 '12 at 16:09
  • 1
    @AirtonSobral That's pretty odd! Worked for me too, except in my case my scrollwheel would jump full page lengths (too fast). Now it's smooth! :) – Web_Designer Aug 2 '13 at 15:55
  • Is this answer up-to-date? – ahorn Jun 17 '17 at 15:45

Just unplug the mouse (mine was wireless), and then plug it back in to fix this issue.

I was searching for a long time for this fix and even rebooted the machine to no avail.

Maybe a full shutdown would have fixed the issue.

  • 2
    This worked for me as well. It's a little annoying that I have to do this on every startup, but oh well, at least it works. – Tamás Szelei Sep 26 '12 at 11:26
  • 2
    A full shutdown didn't work for me but, unplugging and replugging worked! I hope I don't have to do this every restart cycle. – TechplexEngineer Nov 18 '12 at 14:04
  • 4
    Wow, this worked for me too with a Microsoft Wireless mouse that was scrolling far too fast. I unplugged the bluetooth dongle and re-plugged it and scrolling became perfect. Amazing that the fix was this simple. – Gerry Nov 24 '12 at 8:46
  • Surely there is no way to fully express my gratitude within a lifetime, so I'll just say THANK YOU, it DOES work. – AndreasT Jun 25 '13 at 20:09
  • Found the perfect solution. No more unplug and plug. Use resetmsmice, and the Ubuntu package – Ted Feng Sep 30 '15 at 2:02

For Ubuntu 12.10 I found that it it a little different for the Firefox work around.

Open about:config (type it into the address bar) and search for:

mousewheel.min_line_scroll_amount

Then change the number associated with it. Mine was set to 5. I changed it to 60 and it works how I want it now.

  • 1
    Thanks! I found that option myself but didn't try that high a number, just something like 10. But together with smooth scrolling it seems that much higher numbers are in order to reach barely sufficient scroll speeds. Currently got mine set to 100. – nem75 Jan 11 '13 at 12:40

In Firefox 19, run about:config in the address bar, then modify the parameter mousewheel.min_line_scroll_amount to something higher (50). You don't have to restart FF.

Chromium Wheel Smooth Scroller

In Chrome, this is The Soluttion: https://chrome.google.com/webstore/detail/chromium-wheel-smooth-scr/khpcanbeojalbkpgpmjpdkjnkfcgfkhb

Just brilliant!

  • 2
    I used this to solve my problem, worked well for me. – Zzzach... Sep 27 '15 at 7:20

I have Firefox 42.0 here, and I use a touchpad to scroll.

I found if I wanted to adjust the distance scrolled, I could change:

mousewheel.default.delta_multiplier_y

in about:config. Its default value was 100. A larger value would scroll further/faster.

If you use two fingers on a touchpad to scroll, you can use synclient to adjust the sensitivity for the whole system.

If you don't have it installed:

sudo apt-get install xserver-xorg-input-synaptics

To see the current sensitivity threshold, check the output of:

synclient -l | grep ScrollDelta

To make it more sensitive, reduce the value:

synclient VertScrollDelta=33

This means you need to move your finger less to send each scroll event.

If you want to reverse the scroll direction, like Mac OS X's "natural scrolling", set a negative value.

But note that this will not let you configure the minimum distance scrolled when you move your fingers only a little bit. That must be configured per-app (or possibly per-desktop environment).

  • only on Synaptic devices - does not apply to ALPS or indeed any other touchpad manufactuter. – Wyatt8740 Feb 2 '16 at 20:48

Even if the unplug/plug trick does fix the issue this is not a really good solution

One solution I found is to add

xinput set-prop 10 'Evdev Scrolling Distance' 10 10 10

at the end of my .profile file (or wherever it gets executed once per graphical login)

In the case of my Microsoft mouse the default values were 1 1 1 which are way too sensitive.

10 10 10 are right for me.

I didn't take the time to see what each number actually means

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.