I am totally unable to install any flavor of Linux on my lenovo Y500.


  • with EFI on -> cannot even access installer
  • with legacy - > installer runs fine, but installed OS never boots

Long Version:

It is going to be hard to recap what I did, because I tried so many things, but here is the gist of it:

EFI mode (secure boot disabled):

Trial #1

  • ubuntu 12.10 x64 & Mint 14 x64
  • boot from usb
  • see screen with choices
  • pick "try ubuntu"
  • get black screen

Trial #2

  • ubuntu 12.10 x64 & Mint 14 x64
  • boot from usb
  • see screen with choices
  • press "e" to enter edit mode
  • remove "quiet splash"
  • replace with "nomodeset"
  • end up on the command line with an error message from x server: "no screen found"
  • try fiddling around with xorg.conf to no avail

Trial #3

  • Arch Linux Live USB EFI mode
  • no boot

Trial #4

  • ubuntu 12.10 x64 & Mint 14 x64
  • set "e" to enter edit mode in menu
  • add acpi=off
  • end up with "(initramfs) unable to find a medium" message

Trial #5

  • same as above
  • set SATA mode to legacy (it was AHCI)
  • error loop that says something along the lines of "ata1.00: hard resetting link"

Legacy Mode

Trial #1

  • ubuntu 12.10 x64 & Mint 14 x64
  • USB boot
  • Everything seems to work
  • Proceed to normal install (picks SSD drive by default)
  • Everything seems to work
  • reboot
  • blank screen
  • reboot with "shift" pressed
  • see message "grub loading." and nothing
  • As per advised on Ubuntu's community EFI page, run boot-repair
  • same results
  • run boot-repair again
  • same results

Trial #2

  • ubuntu 12.10 x64 & Mint 14 x64
  • same as above, but pick 1T HDD as target install
  • same results

Trial #3

  • create a /boot partition on the SSD
  • install on SSD
  • same results ("grub loading.")
  • run boot repair twice
  • same results

Trial #4

  • create a GPT filesystem on HDD
  • create a /boot partition on the HDD
  • install on HDD
  • same results as above

Trial #5

  • install ubuntu on HDD
  • install boot on all drives (HDD & SSD)
  • same results

Trials #6

  • install Arch on SSD
  • no boot loader found


  • Every step has been tried with multiple USBs.
  • All isos' MD5Sums have been verified
  • LiveUSBs have been created both through ubuntu's embedded app and unetbootin (save for Arch's live USB which was created by DDing the iso as per advised in the Arch wiki)
  • I have wiped out windows in my first trials, and I don't care, I am never going to use it. I don't want to dual-boot. I just want Ubuntu or Mint or Arch
  • as far as I can remember (it gets hard after 50+ trials), I tried every option with sata mode IDE or normal. Not sure though.

I've also tried numerous other things that I can't recall right now.

All in all I've been giving this 3 to 5 hours a day for a week and a half to absolutely no avail.

I am extremely disappointed as this is my first Lenovo and word is Lenovo is Linux-friendly...I have never spent more than an hour installing linux on any machine.

What's even more frustrating is that it seems to be working for some people, and I can't find any hint telling me how they managed. I wrote to one guy who posted a serie of youtube videos about how to get everything working perfectly on the Y500, and he told me he just installed mint without any problems. Might be I am a particular case because I have the SLI version of the Y500.

If anyone has pointers, incomplete solutions, ideas, black magic, I'll be forever in debt.

Thank you

P.S: This question, afaik, is not a duplicate of an existing question. I've scoured all questions containing "lenovo" and "install", and none applies to me.

4 Answers 4


This is how I enabled Ubuntu 13.04 to install alongside Windows 8 with a new (May 2013) Lenovo IdeaPad Y500 (1TB drive, dual NVidia GT 750M).

1) Download a copy of Ubuntu 13.04 x64 desktop ISO and install to a USB flash drive. (http://www.ubuntu.com/download) Create the USB install image following this guide (https://help.ubuntu.com/community/Installation/FromUSBStick)

2) Resize your Windows 8 partition using the built in Windows drive management tool. Just resize the partition down, don't create a new partition in the empty space as the Ubuntu installer will do that. (You may need to do a complete reboot for the resizing to take place.)

3) While still in Windows 8, edit the boot/grub/grub.conf on the new USB flash drive using Wordpad.

Change where it says "set gfxmode=auto" to "set gfxmode=1920x1080"

Under "Install Ubuntu", change "quiet splash" to "nomodeset=1"

So it should look something like this:

if loadfont /boot/grub/font.pf2 ; then
    set gfxmode=1920x1080
    insmod efi_gop
    insmod efi_uga
    insmod gfxterm
    terminal_output gfxterm

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

menuentry "Try Ubuntu without installing" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
    initrd  /casper/initrd.lz
menuentry "Install Ubuntu" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity nomodeset=1 --
    initrd  /casper/initrd.lz
menuentry "OEM install (for manufacturers)" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true --
    initrd  /casper/initrd.lz
menuentry "Check disc for defects" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  boot=casper integrity-check quiet splash --
    initrd  /casper/initrd.lz

4) Install Ubuntu and choose the option to install Ubuntu 13.04 alongside Windows 8. Choose to install the bootloader onto your new Ubuntu partition.

5) After the install is complete, boot again with your USB and select "Try Ubuntu" and let it boot to the text console.

You will not be able to use this new Ubuntu install until you edit this grub.cfg as well. To do this, first mount this new partition, and then edit the grub.cfg as above in the Ubuntu editor of your choice (vi, nano, etc).

sudo mkdir /mnt/newinstall
sudo mount /mnt/newinstall /dev/sdb8
sudo vi /mnt/newinstall/boot/grub/grub.conf

(Same edits as listed in step 3. Also on my install Ubuntu was on the 8th partition /dev/sdb8. Yours may vary so check it first!)

** Note the file is write protected, so make sure you use ":w!" to write from vi.

6) At this point you should be able to boot your new Ubuntu, but you will only be greeted with a hopefully legible text console. The default VESA and nouveau drivers do not support the 750M cards. In addition the Ubuntu provided nvidia binaries are also too old and will not work. (Well I spent several hours without success trying to get them to work.) The solution:

Install the new drivers from NVidia! (please visit the NVidia website and find the relevant driver URL. I have listed the one current as of 2013-May-6):

wget http://us.download.nvidia.com/XFree86/Linux-x86_64/319.17/NVIDIA-Linux-x86_64-319.17.run
sudo chmod +x NVIDIA-Linux-x86_64-319.17.run
sudo sh ./NVIDIA-Linux-x86_64-319.17.run
(follow the installer instructions)

7) You should now have both a functional Windows 8 and Ubuntu 13.04! I would love for the Ubuntu supported nvidia drivers to work, as any kernel Ubuntu updates will force me to have to re-install the nvidia binary drivers.

8) Choose your boot method. You can select "F12" while booting to choose what to boot. To set a default, hold "F2" while booting and you can reorder the boot priority.

  • so you installed a working desktop version this way? or were you just running it off the usb?
    – Derek
    Commented May 4, 2013 at 2:14
  • Yes I have it completely working. Edited above to show *everything * I did. What I had before was the critical piece I needed to get everything else working. You likely will be able to use the Ubuntu nvidia drivers if you have the 650M video card(s).
    – T2Small
    Commented May 6, 2013 at 19:45
  • I'm a bit puzzled by the role of Win8 and UEFI in all that. Suppose I want to replace the HD with a SSD of my own, and install Win7 (or Win8) plus Ubuntu. Can I do that? Commented May 13, 2013 at 22:00
  • 1
    I wish I would have found this earlier, might have saved me a lot of trouble. Yes, the issue with the Y500 is that Nouveau does not support the GT 750M/650M. So, you have to install Nvidia drivers from the command line which is a bit of pain. A direct-dd ISO even had issues. Would work sometimes, not others. Really odd.
    – Chuck R
    Commented Aug 9, 2013 at 10:28
  • Do standard installation.
  • Reboot. Press F2 during reboot.
  • Change boot order of network boot to the topmost.
  • Press F10 to save and reboot.

That's it!

  • Wow; I need to try this. But for now I have solved it by using syslinux instead of grub. Just works.
    – Xananax
    Commented Apr 11, 2013 at 7:59
  • Just imagine how happy i was when i found it working. i got a similar problem with my acer. So it worked with my Y500. I completely removed window$ 8 now running on Linux Mint. Disabled secureboot and efi. now everything works as expected except of wlan. when i download something (slow connection not saturating network capacity) and additionally open a website the ping rises from 30ms to 4000ms ! you know this issue?
    – Alex
    Commented Apr 12, 2013 at 9:48
  • probably you should answer your question or edit it to mention that you solved the problem usin syslinux.
    – Alex
    Commented Apr 12, 2013 at 9:50
  • I agree, since I'm getting a Y500 soon I'd like to know how you solved your problem with syslinux? I'm familiar with syslinux, just not sure how you would have done that? Is it just a hacked-together conf file to get it to boot Ubuntu? Does Ubuntu support this non-standard bootloader? Any information would be nice.
    – Chuck R
    Commented May 3, 2013 at 22:47
  • @axaluss: But answers are still pouring in, and I am not sure mine is the best one. Until I re-format and try the other solutions posted here, I will not.
    – Xananax
    Commented May 5, 2013 at 10:43

lenovo has NVIDIA GeForce GT650M 2GB built in, and, NVIDIA is really big problem with linux...try installing ubuntu, when it booting press CTRL+ALT+F1 and login and run following:

sudo apt-get install linux-source

and after that:

sudo apt-get install linux-headers-3.5.0-17-generic

than try with removing:

sudo apt-get autoremove nvidia-*

and try to install again with:

sudo apt-get install nvidia-current-updates

when you finish all of that, restart your computer. If this helps, then it is a solved issue with NVIDIA card, if not, then it is some other problem.

  • I doubt it, because I either (a) can't install in case of EFI or (b) can install but never get past grub. The video card might be a further issue, but my current problem is either (a) installing ubuntu or (b) getting past grub who just displays "grub loading." I will still try of course
    – Xananax
    Commented Mar 26, 2013 at 10:13
  • hmmmm, let me think little what it should be ok? Commented Mar 26, 2013 at 10:18
  • moreover, 650m is optimus graphics (I think not sure). In that case installing nvidia driver will cause another problem. @Xananax if this laptop comes with optimus, try to search in BIOS,, whether you can disable nvidia card and use intel one.
    – Web-E
    Commented Mar 26, 2013 at 11:00
  • The Y500s are NOT Optimus. While the capability certainly exists due to the hardware, the board actually prevents an Optimus setup. Essentially, the board blacklists the Intel HD on the CPU somehow. So, if your GPU were to die you're SOL. Kind of a crappy way to set the hardware, but good with the bad I suppose.
    – Chuck R
    Commented Nov 22, 2013 at 23:07

I installed remastered Ubuntu 12.04 in legacy mode with Windows 7 & 8 Multi booting.

I just set 1st boot device to HDD, not SSD.

It works! and success to boot all Operating system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .