I installed Ubuntu server 12.04 about 2 weeks ago. It had been working well and running 24/7 until I accidentally restarted it yesterday. Shouldn't have been a problem, yet now it just sits at a black screen. It's not a screen-has-no-signal black screen, it looks like it's actually displaying black all around.

Some facts:

  • It doesn't seem to be connecting to the network.
  • The keyboard NumLock key works.
  • Ctrl+Alt+Del key combination works.
  • The screen is working correctly. I can see the BIOS screens and I can boot into a live USB drive.
  • I recall rebooting the system a few times after I installed it and it was working fine, aside for the fact that the screen would remain at the Ubuntu logo, so I would have to Alt+F2 into another terminal to log in. Everything else was fine.


  • P8H77-I motherboard (using on-board video)
  • 2x ssd drives in raid 1 (using mdadm)
  • Using Grub

The last thing I did before rebooting it was run apt-get update then apt-get upgrade but I don't remember seeing any kernel-related packages in the list.

I've booted from a "live" USB drive I made in order to install Ubuntu, however, I remember having a whole lot of trouble as I had to mount the CD image manually in order to install. I might have to get a real DVD drive and boot off that, but I don't have any optical media :|

Please let me know if you need any more info to help me troubleshoot.

Thanks in advance!

What have I tried?

  • I have tried holding F6 to get into GRUB
  • I have tried booting off a live drive. I believe I have to set "nomodeset" or something, but I don't know how to do that off a live CD on a raided system. Plus, this wouldn't explain why I was able to reboot before but not now.
  • I am aware of similar questions, but this is different because it's not happening right after install.. It rebooted a few times after install, ran for awhile, then this.
  • what is your graphics card? is it nvidia/ ATI ? – Web-E Mar 26 '13 at 4:30
  • Was apt-get process complete before the reboot? – Jason Mar 26 '13 at 4:35
  • yes, apt-get was fully complete.. nothing was running when I rebooted it.. I rebooted it from the console by typing (reboot now) – 0x6A75616E Mar 26 '13 at 4:37
  • Video card is on-board.. Intel Graphics as per ca.asus.com/en/Motherboards/Intel_Socket_1155/P8H77I/… – 0x6A75616E Mar 26 '13 at 4:38

I was able to resolve this issue after a few hours of battling it. It was unfortunate that so many seemingly related questions were caused by something else, so it took some guessing and trial and error to get it working.

First of all, I gather that the issue was that grub was failing to load /vmlinuz or /initrd.img and crashing before anything got to the screen. I believe that running apt-get upgrade at some point had updated the kernel and had not updated grub's settings.

What worked for me:

I booted off an ubuntu server 12.04 live CD and went into "Rescue a broken system". From there I went and selected "assemble raid array automatically", selected my root partition (the raid e.g. /dev/md0) and chose to go on a chroot shell on that directory.

From the shell I had to:

  • Regenerate mdadm's config: mdadm --detail --scan > /etc/mdadm/mdadm.conf
  • re-install grub:
    • grub-install /dev/sda
    • grub-install /dev/sdb
  • Update grub: update-grub
  • Update initramfs: update-initramfs <--- I believe this was the crucial part.

I then restarted the system and boom. Good to go.

P.S. This other question had some important background information that helped me. I did the kernel re-install bit from there, but it didn't work as that was not the problem.

| improve this answer | |

First see which hard drive your computer boots to first and switch it. (They should be identical including mbr if I'm not mistaken.) Try this even if you have both of them as boot options since it sounds like one is starting to boot before the troubles start.

It's likely that your drives are out-of-sync. If you don't have bios-level raid management I recommend disconnecting one and boot up. Check the system thoroughly since which ever drive you "keep" is going to define what data & software you'll have when this is over. If it still won't boot try switching them. Once you have a working drive add the other as a new drive and let the system copy everything.

If you do have bios-level raid management I recommend disabling in software rather than hardware but doing otherwise the same as above.

| improve this answer | |
  • I'm running a software raid with mdadm, the drives are brand new and I specifically checked that they were in sync a few minutes before the reboot happened. I have tried booting from both independently and I get the same black screen. – 0x6A75616E Mar 26 '13 at 5:13

If u have an windows system try downloading rufus http://rufus.akeo.ie/ and mount the server iso in your usb stick and reinstall your server

| improve this answer | |
  • I already have a bootable USB installer. How is re-installing a long term solution? – 0x6A75616E Mar 26 '13 at 5:11
  • It worked for me the same thing happened to me when i reinstalled it worked – samnaction Mar 26 '13 at 5:35
  • Yeah.. reinstalling wasn't really an option for me.. I got it fixed tho :) – 0x6A75616E Mar 27 '13 at 5:49
  • how did u fix it ????? – samnaction Mar 27 '13 at 6:19
  • see my answer for details – 0x6A75616E Mar 27 '13 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.