4

So I wiped my Mac Mini (OS X Lion) and replaced the OS with Ubuntu 12.04.2. So far so good, it works beautifully. But I'd like to still access the external backup drive's Time Machine contents. The drive was untouched during the install of Ubuntu. It's just an external 1TB USB drive. Problem is, the partition type is AF05 (Apple Core Storage) and not HFS+. Is there a way to mount this in Linux or am I stuck with having to find another Mac to do the data restore?

Here's the relevant disk layout info:

GPT fdisk (gdisk) version 0.8.1

Type device filename, or press <Enter> to exit: /dev/sdb
Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): p
Disk /dev/sdb: 1953525165 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 44A9E054-ABBA-4788-8D47-D473709370CB
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525131
Partitions will be aligned on 8-sector boundaries
Total free space is 10 sectors (5.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              40          409639   200.0 MiB   EF00  EFI System Partition
   2          409640      1953262983   931.2 GiB   AF05  TIMEMACHINE
   3      1953262984      1953525127   128.0 MiB   AB00  Booter 0x43773a38

And what I'd like to get at is that TIMEMACHINE partition, /dev/sdb2. Is there any hope?

2

I found this paper which analyzes the security of FileVault 2 and the authors wrote this library which allows access to CoreStorage partitions via fuse.

Here's how to mount encrypted partitions, but I haven't tried it yet. They also mention on the front page that non-encrypted partition support is still being worked on.

0

The best option that I've found thus far is to boot into MacOS recovery(you'll have to create a recovery disk), disable FileVault protection from there, and then to boot into linux (14.04 in my case) and mount the now HFS+ partition using hfsexplorer and extract the files that way. I know it's not quite what you're looking for, but more of a workaround to get at your files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.