I have been getting the following problem running Ubuntu 12.10. Basically, it freezes completely, doesn't respond to keyboard or mouse, CAPS won't change and alt+sys req+REISUB doesn't do anything. The problem is consistent in that after a hard reset it will be fine for a while but will freeze at some point. I've tried booting from a startup USB and this also froze so it isn't a OS problem, some hardware issue. Today I got the following messages before it froze. I guess what I want to find out is which hardware component is failing?

This is my laptop http://www.amazon.com/Sony-VAIO-Series-VGN-NS305D-Notebook/dp/B002F1PSQ8

Intel Core 2 Duo Processor T6670 2.2 GHz

2MB L2 Cache, 800MHz FSB Speed

2GB DDR2-800 RAM Max - 4GB

160GB (5400RPM) SATA Hard Drive

[Hardware Error]: CPU 0:  Machine Check Exception: 4 Bank 5: f200141014040400
[Hardware Error]: TSC Zc124d6Zdd
[Hardware Error]: PROCESSOR 0: 1067a TIME 1364221737 SOCKET 0 APIC 0 microcode a07
[Hardware Error]: Run the above through 'mcelog --ascii'
[Hardware Error]: CPU 1: Machine Check Exception: 5 Bank 0: f200084000000800
[Hardware Error]: RIP !INEXACT! 10:<ffffffff81031f8f> {mwait_idle_with_hints +0x5f/0x80}
[Hardware Error]: TSC Zc124d70df
[Hardware Error]: PROCESSOR 0: 1067a TIME 1364221737 SOCKET 0 APIC 1 microcode a07
[Hardware Error]: Run the above through 'mcelog --ascii'
[Hardware Error]: CPU 1: Machine Check Exception: 5 Bank 5: f2001410300c0400
[Hardware Error]: RIP !INEXACT! 10:<ffffffff81031f8f> {mwait_idle_with_hints +0x5f/0x80}
[Hardware Error]: TSC Zc124d70df
[Hardware Error]: Machine check: Processor context corrupt
Kernel Panic - not syncing: Fatal Machine check
panic occurred, switching back to text console
Rebooting in 30seconds ..
  • Hi evan, usually kernel panic is not a good sign. Did you search for bug reports? – don.joey Mar 25 '13 at 16:47
  • no... where should i search... I usually find very generic results... and the most useful results I found as replies to posts here or elsewhere.. – evan54 Mar 25 '13 at 16:54

Machine check exceptions are thrown when a CPU detects a hardware problem. This is not a OS related thing, but an actual hardware failure.

They can be caused by:

  1. Random things (e.g. cosmic rays). This will happen now and then, but only very rarely. If your problem persists then this is not the cause
  2. Broken hardware (Can be the CPU itself, or e.g. the memory when it tried to access the memory and gets corrupted/unexpected results)

In your case: Open the laptop. Check the CPU. Is it properly cooled? No dust on the heatsinks (Heat warning should kick in before the CPU starts to crash, but still...).

Are they any bulging capacitors? Any other visible damage?

  • hm... I can't open the computer right now but I think it may just be time to get a new computer... Seems like a bit of a waste on a small issue... There definately is physical damage, on the heat sink on the exit although I'm pretty sure it's not an over heating issue. The other thing I've read a bit about is with regards to power supply units, I burned out the original and bought a replacement with almost the same voltage output 19 or 20V instead of 19.5V, could also have caused failure... – evan54 Mar 28 '13 at 9:47
  • Re PSU: Does the problem occur when the system is powered only by the battery ? (Not that 20v to 19v is that huge. Or rather 20-ish volt to 19-ish volt. Usually a replacement works as long the the new PSU can supply at least the same amperage as the old one and it the voltage is close enough. 100% precise matches are not needed). – Hennes Mar 28 '13 at 10:21
  • yeah it still has the problem only on the battery and only on the PSU. I know this kind of is contradictory to what I said before... – evan54 Mar 28 '13 at 14:55
  • I'd say it isn't the 20v power supply that's the problem. The voltage difference should be well within its tolerance. The power supply would need to safely deliver the number of milliamps or watts that the computer needs, but if it was built for a laptop, it should. – thomasrutter Dec 23 '14 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.