My wubi installation of Ubuntu 12.04 is stuck in an infinite login screen loop. I have tried following the advice on other posts but nothing has worked so now I'm trying to retrieve a few files from root.disk from Windows7.

Here is what I have tried:

I booted into ubuntu and when faced with the login screen ctrl+shift+F1 and logged in with that. Updated all my packages and tried to log in the usual way again. No Dice.

I logged in that way again and tried to copy some files over to /media/DATA (this is a general purpose windows-friendly storage partition). Permission Denied. sudo doesn't work and su wont accept my password.

I got into recovery mode root and opened up /media/DATA . ls tells me that it is empty (it is not). I made a new folder for my backups. This new folder shows up with ls. cp started the copy without complaint but then I ran out of disk space on DATA. I booted into Windows and the backups directory isn't where I left it and I have loads of space left. Back in recovery mode the backup folder is still visible but nothing else on DATA is... spooky.

My next approach was to find something that I could use to open up root.disk via windows. I have seen lots of recommendations for programs on this forum but they either dont work on windows7, only have corrupted versions available for download, or just wont open the .disks as is.

So my question is:

How can I make data stored in a wubi disk image available to Windows7?

  • In recovery mode, from a root prompt, what's the output of df -h? I'm interested in seeing how much space is available for /dev/loop0 mounted as / – bcbc Mar 25 '13 at 17:47
  • Possible duplicate of: askubuntu.com/questions/9933/… – bcbc Mar 25 '13 at 17:57
  • @bcbc: it's not a duplicate, that question is about making use of a partition. I need to read a .disk file so there's also the problem of mounting it (or something) in windows – Sheena Mar 25 '13 at 20:29
  • Ext2read mounts and reads .disk files as well. – bcbc Mar 25 '13 at 20:30
  • @bcbc: cool. downloading it now. Version 2.1 works great. 2.2 less so... – Sheena Mar 25 '13 at 20:38

Use this tool: ext2read

Download, extract, run, open up the \ubuntu\disks\root.disk file, and copy your data.


I once had this problem and none of the suggestions worked. What I ended up doing is installing another login manager, like slim and the rebooting

Worth a try...


Two ways that could work:

  • Log in with Ctrl + Alt + F1. Switch to Ctrl + Alt + F7 when logged in.

  • Log in with Ctrl + Alt + F1, then type startx.

Tell me if it spits out any errors. Or, tell me if it works.

Hope this helps!!!

  • The first option doesn't work. If I log in in text then go back to the Gui it acts like I'm still logged out. I'll get back to you on the second point in a bit... – Sheena Mar 25 '13 at 20:31
  • Ok. Hope startx works. – horIzoN Mar 26 '13 at 12:27
  • Oh, on the first step try and do a admin thing. See if it asks for a password. – horIzoN Mar 26 '13 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.