I found nothing about this specific problem on the internet so I'm asking for help here:

Once I had Windows 7 and Ubuntu on dual boot working flawlessly. Then I bought a new internal 1 TB HD and decided to install Win 7 and Ubuntu on it. I followed these steps after plugging the new HD (thus having two HDs):

With Win7 installation dvd:

  1. On my new internal HD (1TB) I created 3 primary MBR partitions formatted as NTFS and left some free space to later install Ubuntu. (1st partition with 200 GB for Windows, 2nd and 3rd with 300 GB each to keep media and other documents, and 200 GB of free space).
  2. I installed Win7 Ultimate on the first partition (200 GB) without problems, transfered my media files to 2nd and 3rd partitions and formatted my old HD (which has 250 GB).

Then I inserted Ubuntu live CD to install it and rebooted as it demanded:

  1. The machine booted with live cd but when I got the choose-what-to-do installation screen, it didn't show me the option to "install alongside Windows". There was only two options, "install ubuntu" and "something else".
  2. I chose "something else" and followed till the partitions-handling screen. This screen did show all 3 primary NTFS partitions with correct sizes and the unpartitioned space.
  3. Then I created 3 logical partitions on the free space (one for /, other for /home and other for swap) and chose to install bootloader on the HD (not on any particular partition).

After finished the installation process I rebooted as normal and, as I already suspected that could happen, the machine booted directly onto ubuntu. As the installer didn't recognize the win7 installation, there was no entry for it on grub2.
Then, more odd, when I opened Nautilus, the 2nd and 3rd NTFS partitions with my media files WERE there for me to mount and access (and I did access them without problems), but the Win7 partition simply wasn't there. The same happened on Dolphin and Krusader when I tried them.
Still odd, Disk Utility DOES show win7 partition and shows that it is NTFS and has a bootable flag, but under "Usage:", where other partitions say "filesystem" it shows only a "-", no label (or "unknown" on the graphical representation of the disk) and no possibility to mount.
I then opened terminal and tried "sudo blkid", and got no return but a popup saying that blkid has crashed. On the details of the message, the title of the message is blkid crashed with SIGSEGV in blkid_do_safeprobe()", the SegvReason says "reading unknown VMA and the SegvAnalysis says:

Segfault happened at: 0x7fa9ac7e17b6:   mov  0x4(%rsi),%eax  
PC(0x7fa9ac7e17b6) ok  
source"0x4(%rsi)" (0xfffffffffa1e8c4c) not located in a known VMA region (needed readable region)!  
destination "%eax" ok  

Oddly enough, when I tried sudo fdisk -l it DID show a list of all partitions correctly, INCLUDING the 1st NTFS partition with correct size, boot flag, but no mount point and nothing about it having windows on it.
I rebooted the machine several times, and whenever I open any program that calls blkid I get this popup saying that blkid crashed, for example, "NTFS Configuration Tool", "MountManager" AND sometimes even the native Ubuntu updater makes blkid crash in the middle of the update, although the overall update process never stalled.
Also, when I try to mount that partition on terminal using "mount" command (with or without sudo), it returns that I don't have permission to do that, even though I am the only user and it's an administrator account.

After all that, I still had to do some tweaks to be able to boot on my Windows7 (restore Windows bootloader and, on Windows, use EasyBCD to add an Ubuntu entry on the win bootloader 'cause I don't know how to edit Grub2 manually and even if I did, I'm not sure it would work given the situation).

To try one last thing, I formatted and excluded the logical partitions where Ubuntu was and reinstalled Ubuntu on that old 250 GB HD I still have. But the results were EXACTLY the same. Here's what sudo fdisk -l returns (sda is aa third HD I didn't mentioned cause it only has some old files and no OS. Windows is on sdb1 and Ubuntu is now on sdc):

Disk /dev/sda: 120.1 GB, 120060444672 bytes  
255 heads, 63 sectors/track, 14596 cylinders, total 234493056 sectors  
Units = sectors of 1 * 512 = 512 bytes  
Sector size (logical/physical): 512 bytes / 512 bytes  
I/O size (minimum/optimal): 512 bytes / 512 bytes  
Disk identifier: 0x3d8a3d8a

   Device Boot      Start         End      Blocks   Id  System  
/dev/sda1            2048   234489855   117243904    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes  
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors  
Units = sectors of 1 * 512 = 512 bytes  
Sector size (logical/physical): 512 bytes / 4096 bytes  
I/O size (minimum/optimal): 4096 bytes / 4096 bytes  
Disk identifier: 0x1b8c281d

   Device Boot      Start         End      Blocks   Id  System  
/dev/sdb1   *        2048   419432447   209715200    7  HPFS/NTFS/exFAT  
/dev/sdb2       419432448  1048578047   314572800    7  HPFS/NTFS/exFAT  
/dev/sdb3      1048578048  1677723647   314572800    7  HPFS/NTFS/exFAT  

Disk /dev/sdc: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors  
Units = sectors of 1 * 512 = 512 bytes  
Sector size (logical/physical): 512 bytes / 512 bytes  
I/O size (minimum/optimal): 512 bytes / 512 bytes  
Disk identifier: 0x7d822705

   Device Boot      Start         End      Blocks   Id  System  
/dev/sdc1   *        2048    70596607    35297280   83  Linux  
/dev/sdc2        70598654   183271423    56336385    5  Extended  
/dev/sdc5        70598656   175458303    52429824   83  Linux  
/dev/sdc6       175460352   183271423     3905536   82  Linux swap / Solaris  

The only thing I didn't try was to format Windows and install it on the old HD because I already have too many things set up on Windows and to reinstall it would be too laborious.

Searching internet for this problem, I only found one similar problem, but I'm not sure it's the same situation I have: There's a (long inactive) bug report from a guy that couldn't access his EXTERNAL HD and blkid crashed whenever he tried. But on that case, besides being an external HD, that guy seemed to have no OS installed on it. And on my case, it seems that the presence of Windows is what's preventing access to the partition since all other partitions are perfectly accessible.

Can anyone tell me what's wrong?


Yesterday, after updating Ubuntu, this problem has magically disappeared.
Win7 partition is now perfectly accessible, Grub now shows an entry for Windows and blkid returns what was expected without crashing!
I don't know if the dozens of crash reports I sent made any difference, but the fact is that the bug is gone.

Thank you Ubuntu team!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.