6

I have configured Apple trackpad on Ubuntu 12.04 in xorg.conf as suggested here.

I have also added

"TapButton3" "0" 

but it does not disable three finger tap.

My Question

How to disable three finger tap of trackpad in xorg.conf?

  • What does three finger tap currently do for you? Is it middle click, or is it a Unity gesture? – edm Apr 1 '13 at 15:05
  • It is used to move the windows on the desktop. – Gaurav Agarwal Apr 1 '13 at 15:41
1

Run the following in a terminal

synclient ClickFinger3=0
synclient TapButton3=0

If this does the trick (or a variance of 0 , 1 , 2, 3 , ) you can add it to startup.

(note i do not have a macbook,but it works on my asus. Please let me know if this does nothing at all)

| improve this answer | |
  • synclient TapButton3=1 worked for me on my Macbook 6,1 using Ubuntu 12.04... Thanks! :D – Cashew Sep 7 '13 at 15:24
  • Scratch that, I used the value 2 instead of 1 and it worked better – Cashew Sep 7 '13 at 20:59
  • 1
    yep, set the value to 2 as per this answer . Works for me on my 13" MacBook pro – Jujhar Singh Jul 27 '14 at 20:56
0

Disabling unity gestures is much more difficult than editing the xorg config file. They are build into the unity package itself. It is possible to disable all gestures by follow this instructions on the post here:

https://askubuntu.com/a/205045/41562

The commands/files given may be slightly different depending on the current version number of Unity. This "fix" will not persist if unity is updated. You can disable updates for unity using the command below but you will not get bug and security fixes:

echo "unity hold"|sudo dpkg --set-selections

| improve this answer | |
  • I will not like to disable upgrades to Unity, instead can I decrease the sensitivity of three finger touch. – Gaurav Agarwal Apr 2 '13 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.