15

When running sudo aptitude upgrade, the console freezes for long after almost every package upgrade with a message "Processing triggers for man-db ...". What could be the problem and how can I fix it?

Ubuntu version: 12.04 (both Server and Xubuntu)

Thanks in advance.


Update: It looks like this problem is related to package autofs upon my further tests. Removing autofs resolved the issues. No idea why. I then have to use soft links instead of autofs for my file system to avoid this issue (and other two issues posted here as well).

1
  • I have the same problem, will see if removing autofs helps. Thanks! – Lukas Stejskal May 1 '13 at 8:54
8

Might be helpful for someone: I ran into this issue on our CI regularly.

Just execute the following:

sudo apt-get remove -y --purge man-db

The command removes the man-db package completely, which in our case on CI, was completely useless anyway.

1
  • Hmm, on ubuntu this wanted to remove ubuntu-standard, which seems like a bad idea – Kevin Mar 13 at 1:32
7

It's possible the mandb index is corrupted.

check the index and recreate it

sudo mandb -t
rm -rf /var/cache/man
sudo mandb -c
3
  • This is the solution and works. – Bhikkhu Subhuti Oct 1 '20 at 6:33
  • didnt work for me – Adeerlike Oct 13 '20 at 21:15
  • I'm not sure it's necessary to remove the cache prior to invoking mandb with the -c flag. According to the man page: -c, --create By default, mandb will try to update any previously created databases. If a database does not exist, it will create it. This option forces mandb to delete previous databases and re-create them from scratch, and implies --no-purge. This may be necessary if a database becomes corrupt or if a new database storage scheme is introduced in the future. – chb Oct 18 '20 at 2:25
5

I had something similar just after installing Ubuntu 18.04 on Windows Subsystem for Linux and running update and upgrade: it got stuck at processing triggers for man-db (2.8.3-2). And also later, after running

sudo apt install python3-pip

My solution: I just waited. In the second case even some 15 minutes. I do not know whether this is normal, as I am very new to Linux. But this so people just know another experience if they run into the same problem.

1
  • The reason this is slow on WSL1 is because of slow I/O on WSL1. It is a known issue. – narendra-choudhary Apr 19 '20 at 15:49
0

I have had the same problem when I was installing apache web server on my digital ocean droplet. After waited a bit, I simply just stop the process and rerun the command. It shows the apache is already installed and it worked. I hope it can still help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.