2

After hitting "Yes" on "Do you wish to continue?" I get

fsck from util-linux 2.20.1
/dev/sda1: clean, 166400/2444624 files, 906859/9765755 blocks

With a blinking cursor on the line below it. From here, the only thing I can do is power off and start up again, and I'm still in read-only mode.

Background:

I'm using a Toshiba Portege R100, a laptop that lacks a CD drive and can't boot from a USB stick.

I removed the R100's hard disc, plugged it into a Mac (over USB) that was in "Try Ubuntu" mode using a DVD,and then I installed Ubuntu onto the R100's hard disk.

With the hard disk back in the R100, on start-up, after the GRUB menu, with Ubuntu selected, it displays the Ubuntu logo then goes into "Low-Graphics Mode," covered here:
How to fix "The system is running in low-graphics mode" error?

In attempting to try the various fixes reported there, I have to use Recovery Mode, which leaves the disk, by default, in read-only mode.

And that's where I try "Enable Networking," which results in the blinking cursor (crash?).

I have also tried dropping to the shell and trying
# mount -o rw,remount /

which is the fix here, http://ubuntuforums.org/showthread.php?t=1870817

But that doesn't work. I just get a new prompt, as if I entered a return, and the system remains read-only.

  • Thanks for the edit, VedVals. The code blocks make this much more readable. – David Mar 28 '13 at 16:45
3

Another (better) answer, is that for the Enable Networking command, you have Network access. Who would have thought? ; ) So, when in the terminal, get hard-wired-in, of course.

0

Ok, I have no idea why this works, but it does. To recover from Low-Graphics Mode into a working terminal with the disk set in rw mode, if Ctrl-Alt-F1 gets you a blue screen:

On boot, choose Advanced Options from the GRUB menu

Choose Recovery Mode

When the menu appears, choose Resume Normal Boot

{Low-Graphics Mode}

THEN Ctrl-Alt-F1 works fine, then login.

0

Use the following commands by activating the root shell:

ifconfig eth0 up 
dhclient eth0
  • Well, this is for enabling the Ethernet wired connection. – Joshua Salazar Feb 8 '18 at 17:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.