0

After installing Ubuntu 12.10 on my late-2009 Macbook Pro (7,1), I was experiencing very slow wifi speeds, sometimes dropping below 1 kb/s and never reaching much higher than 45 kb/s. I tried installing wicd and apt-get purge'ing network-manager, and my connection was actually fine for a little bit, until wicd started slowing down, too, and eventually stopped working altogether, so now I have no access to the internet on my Macbook other than ethernet.

I apt-get install'd linux-headers-generic, and then apt-get install'd bcmwl-kernel-source, and, when I tried to "sudo modprobe wl", I was shown the error:

"FATAL: Error inserting wl (/lib/modules/3.5.0-22-generic/updates/dkms/wl.ko): Invalid argument"

What am I doing wrong here? Should I install a different driver?

The results of "lspci -nn | grep 0280" are as follows:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11/a/b/g/n Wireless LAN controller [14e4:432b] (rev 01)
1

There is some controversy about the best driver for this device. Let's try the first of two methods. Temporarily hook up the ethernet and do:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree

Reboot and let us hear from you.

  • Thanks for your response! Sorry for the late reply, but when I rebooted my computer after completing those two steps, I found my connection was as slow as ever. I tried purging wicd, installing network-manager, rebooting, and connecting to my router again, but network-manager was just as slow, with downloads averaging at about 1600 B/s. Do you have any suggestions? – jacobbsny10 Mar 27 '13 at 23:21
  • Let's see: dmesg | grep -e eth1 -e wl – chili555 Mar 27 '13 at 23:27
  • pastebin.com/GcFJNjNH – jacobbsny10 Mar 27 '13 at 23:42
  • I notice this: "b43 ssb0:0: wlan0: disabling HT as WMM/QoS is not supported" Please try a driver parameter: sudo modprobe -r b43; sudo modprobe -r ssb; sudo modprobe b43 qos=0 If it helps, we'll write a conf file and make it persistent. You might also try turning off N speeds in the router, if any. – chili555 Mar 28 '13 at 1:09
  • Hm... It seems like "sudo modprobe b43 qos=0" didn't make too much of a difference, really, and my wifi still seems to be inconsistent, every now and then disconnecting and reconnecting on it's own, or forcing me to reconnect manually. Do you have any other suggestions? Also, forgive my obvious novice-ness, but how would I go about turning off N speeds on my router? – jacobbsny10 Mar 28 '13 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.