I'm having trouble installing skype on a new 12.04 install (64 bit). Below are the results of three different attempts and the outputs. Any help will be greatly appreciated!

  1. Download skype .deb file from skype website, I chose Ubuntu 12.04 (Multiarch). Open the deb file with Ubuntu Software Center and I get:

    Error: Cannot install 'libasound2:i386'
  2. Synaptic Package Manager: I mark skype for installation (and the dialogue box for additional changes lists a ridiculously long list of packages to be removed! but anyway) I click OK, and get an error:

    Could not mark all packages for installation or upgrade:
    The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.
    Depends: skype-bin
  3. Tried the instructions from help.ubuntu but I get

     $ sudo dpkg --add-architecture i386
     dpkg: error: unknown option --add-architecture

But one way or another I think I sorted this out, so:

$ dpkg --print-foreign-architectures


This is what my sources.list looks like:

deb http://archive.ubuntu.com/ubuntu precise main universe restricted multiverse
deb-src http://archive.ubuntu.com/ubuntu precise main universe restricted multiverse #Added by software-properties
deb http://security.ubuntu.com/ubuntu/ precise-security main universe restricted multiverse
deb-src http://security.ubuntu.com/ubuntu/ precise-security main universe restricted multiverse #Added by software-properties
deb http://cran.r-mirror.de/bin/linux/ubuntu precise/
deb http://archive.canonical.com/ precise partner
deb-src http://archive.canonical.com/ precise partner

I then run sudo apt-get update and sudo apt-get upgrade and finally:

$sudo apt-get install skype:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 default-jre-headless : Depends: openjdk-6-jre-headless (>= 6b23~pre11-1ubuntu1~)
 libatk-wrapper-java : Depends: default-jre or
                       Recommends: libatk-wrapper-java-jni but it is not going to be installed.

 skype : Depends: skype-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I then try also:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I've also done clean,autoclean, dist-upgrade with no obvious effect.Not sure where to go from here!?

  • Does this help? askubuntu.com/questions/177010/… – Grimtech Mar 23 '13 at 21:39
  • No, I tried installing ia32-libs, but I got unmet dependencies Depends: ia32-libs-multiarch, which seems to be a bug? – maja zaloznik Mar 23 '13 at 23:45
  • Hmm... similar. A similar issue installing Skype on debian, this page says, " The only fix I know short of installing 32-bit Wheezy in a chroot or virtual machine is to satisfy all of the dependencies, which will all need to be i386 versions. Don't worry; both the i386 and amd64 versions can be installed side-by-side." Stand by, I'm trying to replicate your issue on my machine. – Grimtech Mar 24 '13 at 3:04
  • You may also check this thread: askubuntu.com/questions/215298/… – Ahmadgeo Mar 25 '13 at 1:23
  • Thanks @Ahmadgeo, I've tried all the suggestions in there - unsuccessfully - except for the 'downgrade' one, which is uncorroborated and a bit scarier than the rest (for a newbie). Would anyone else suggest that? And would I need to revert after the skype installation? – maja zaloznik Mar 25 '13 at 12:45

Check these steps;

First install the dependencies by this command in a terminal window(or use Synaptic):

sudo apt-get install lsb-core ia32-libs libqt4-dbus libqt4-network libqt4-xml libasound2

sudo apt-get -f install

Then, download the 64 bit deb package from the official website by:

wget -O skype_Ubuntu-current_amd64.deb http://www.skype.com/go/getskype-linux-beta-ubuntu-64

Now, install skype:

sudo dpkg -i skype_Ubuntu-current_amd64.deb sudo apt-get -f install

Source: http://ubuntuguide.net/how-to-install-skype-on-amd-64-bit-ubuntu-12-04-precise

| improve this answer | |
  • Tried that, the latter 4 packages are already newest versions, while ia32-libs: Depends: ia32-libs-multiarch and lsb-core: Depends: libc6-i386, lib32z1 but is not going to be installed. – maja zaloznik Mar 25 '13 at 12:41
  • Although not a solution :), would you try to install Skype on a new installation (on a Virtual Machine perhaps) and see if you got the same problems.... That would give a clue if the issues really due to your 64-bit installation or you have something wrong in your particular machine :( – Ahmadgeo Mar 25 '13 at 18:40
  • 1
    Meanwhile; I'll do it myself later on on a VM trying to reproduce/solve the problem and will feed you back. – Ahmadgeo Mar 25 '13 at 18:42
  • Also check this, help.ubuntu.com/community/Skype – Ahmadgeo Mar 25 '13 at 18:55

Here is what I've done on the Virtual Machine

1- Install Ubuntu LTS 12.04.1 (No updates made to the system or installation of any extras or even additional language packs)

2- Browse to http://www.skype.com/en/download-skype/skype-for-computer/ and I got automatically redirected to Skype for Linux

3- I selected Ubuntu 12.04 Multiarch and clicked open instead of save. so it got executed directly after download.

4- On initial run, it opened Ubuntu Software center and gave me the same error as you (dependency error with libasound2)

5- I just opened downloaded file location on tmp and copied the file to my Desktop and executed it again.

6- It gave no more errors and just started to install :)

7- Installation took about 10-15 minutes and I noticed that there are Network activity and background downloads from canonical destinations (I guess it was downloading required dependencies).

8- After almost 15min as I said, Skype got installed and I logged to it and made a test call with no issues :)

So; what I think is: - Skype requires active internet connection during installation. so make sure of that. - Re-download and Copy the file to your Desktop and run it from there (Don't know why but just to reproduce my steps) - This is the package I downloaded : http://download.skype.com/linux/skype-ubuntu-precise_4.1.0.20-1_i386.deb

  • If above steps like I did didn't fix your problem, I guess that there is/are some corrupt or misconfigured package(s) related to dependencies and this is the cause of your issue.

  • try to remove/purge all dependencies listed in my other answer and either install them again, or try to install Skype first and see if it made it for you.

Wish this solves your problem :)

| improve this answer | |
  • Nice one, but unfortunately moving the .deb file around did not change anything. Then I did sth. really silly: remove libasound2 which ruined everything from chrome to gnome, and landed me in a "low graphics mode" boot which I barely managed to dig myself out of... I am now seriously considering a fresh install - but this one was only two weeks old, and everything else seemed fine?! Maybe I'll go for 12.10 this time.. Thanks so much for your help though! – maja zaloznik Mar 26 '13 at 14:37
  • Sorry to hear that :( – Ahmadgeo Mar 26 '13 at 15:45
  • From recovery/low graphics mode you may run sudo apt-get install libasound2 to redownload and install the removed package. Then run sudo apt-get -f install which will attempt to correct a system with broken dependencies in place – Ahmadgeo Mar 26 '13 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.