I'm trying to use a free service using the OpenVPN protocol using OpenVPN's GUI module in the network manager.

The config worked perfectly well as .ovpn on Windows. The behavior in Windows is such that I ran OpenVPN GUI and chose to connect to this particular VPN. It would then show the activity in the attempt to connect and opens a dialog box for username/password authentication.

I've successfully imported all the configurations by changing the file type to .conf and using the import feature in network manager. However, attempting to connect would simply display the network manager's attempting to connect animation, but ultimately end with a notification of connection timing out. No prompt asking for authentication would appear at all, nor can I find any feature to prefix the authentication details.

dev tun
proto tcp
remote miami.proxpn.com 443 
resolv-retry infinite
ca ca.crt
cert client.crt
key client.key
cipher BF-CBC
keysize 512
verb 4
mute 5
tun-mtu 1500
mssfix 1450
reneg-sec 0

# If you are connecting through an
# HTTP proxy to reach the actual OpenVPN
# server, put the proxy server/IP and
# port number here.  See the man page
# if your proxy server requires
# authentication.
;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]

Needless to say, but I've downloaded all the required packages for setting up OpenVPN connections.

By the way, as you can see above, .key and .crt files location are specified to be in the same directory as the config file. After importing the config file, if I were to remove them, would it cause any problem? Note, I haven't removed them, so the problem I'm facing is not due to the absence of these files.


Try connecting to VPN from command line. This will make sure that the problem is with NetworkManager and not something else. You can connect from command line using:

openvpn --config /path/to/config.ovpn

You may need to run this command using sudo.

If you can successfully connect from command line then try adding yourself to netdev group and uncheck Available to all users in vpn settings window in NetworkManager and then try connecting using NM.

  • 1
    As expected, it connected perfectly on the attempt in Terminal. It did need sudo privileges. – Oxwivi Feb 28 '11 at 17:04
  • So, did you try adding your self to 'netdev' group, unchecking 'Available to all users' in connection properties in Network Manager and then connecting through Network Manager ? – binW Feb 28 '11 at 17:52
  • How do I do that on the command line? I'm on a minimal install, and the GUI for user management is not installed. – Oxwivi Mar 1 '11 at 8:17
  • you can add user to 'netdev' group using following command "sudo usermod -aG netdev <user-name>" – binW Mar 1 '11 at 9:00
  • ... It worked... But it didn't ask me to authenticate... WTF? – Oxwivi Mar 1 '11 at 9:24

I think tail -f /var/log/{syslog,messages} followed by reconnecting the VPN could give some answers.

  • Reconnecting? It doesn't connect at all. – Oxwivi Feb 28 '11 at 8:05
  • 1
    If it does not connect, it will spit out error messages. – Lekensteyn Feb 28 '11 at 9:16

See the respective bugreport on launchpad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.