I've been having trouble lately with installing the daily build from geary. First of all, I did the following on my terminal, which would get me the latest daily build. Code:

sudo apt-add-repository ppa:valateam/ppa 
sudo apt-add-repository ppa:yorba/daily-build
sudo apt-get update && sudo apt-get geary

Recently, Yorba has released Geary 0.3. But when I installed Geary, the About window shows me 0.2.2+ trunk when it should show 0.3. Perhaps, there is an issue with the package management. I ran this on Ubuntu 13.04 daily build, which updates fine.

I thought by uninstalling geary and installing from scratch would fix the problem, but it doesn't seem that straightforward.

sudo apt-get purge geary && apt-get autoremove

The code removes the app, but doesn't remove any configuration whatsoever. For instance, on a fresh install, my 4 email accounts that I set up were still there.

I really wish to run the daily build on my computer, and I don't want to be stuck with what really isn't 0.2.2+ trunk. How can I troubleshoot this issue and install the daily build? One solution I have is to reinstall the Ubuntu daily build, but I think it's unnecessary.

1 Answer 1


This isn't an Ubuntu problem, it's a problem with the PPA you're using. If you view the packages available you'll see that Geary doesn't have any raring packages. As such, when you install geary via apt-get it's only going to grab from the archives, version 2.2, and not from the PPA as there are not packages built for geary for raring in the PPA.

  • I edited my question to show another ppa. I also tried their daily build ppa. Note that the raring package was around since March 22, and to this day, I can't get the raring package from that repository.
    – jjkim
    Mar 24, 2013 at 17:00
  • This is the result of apt-cache of Geary on my raring. For some reason, I have three geary packages installed in my system. How can I get rid of the two?
    – jjkim
    Mar 24, 2013 at 17:06
  • Erm, apt-cache doesn't say they're all installed. It searches the cached apt list data to find your match. You probably only have the one installed, Version: 0.3.0+934~raring1 which has Status: install ok installed.
    – Thomas Ward
    Mar 24, 2013 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .