Look at the video; the iPhone is supposed to appear as a photo collection of some sort but nothing happens with my iPhone! I have installed and upgraded all of the libimobiledevice versions.

I have tried to mount the iPhone with ifuse /mnt/iphone/ but the result of that operation is:

GNUTLS ERROR: A TLS packet with unexpected length was received.

Hi, how do I connect my iPhone to my laptop (Ubuntu 10.04) so that I can sync music and be able to look at it as a USB stick? (This is what I am expecting to happen.)

When I connect it to my laptop, nothing happens - it doesn't show up as an icon or as a mass storage device.

My iPhone runs iOS v4.2.1 and it's an iPhone 3G. It's not jailbroken for the moment; would that be a problem? My laptop is an Asus 1201n with Ubuntu 10.04 (64-bit).

Bus 002 Device 005: ID 05ac:1292 Apple, Inc. iPhone 3G

I connected my Ipod Video (30 gb) and that one doesn't appear as well So I'm kind of stuck now. The problem probably lies in the system, because the usb port is working.

Bus 002 Device 006: ID 05ac:1209 Apple, Inc. iPod Video

I have added this PPA, I have done all of the sudo update and upgrade. but my computer doesn't realize that my iPhone is connected, whish isn't related to libimobiledevice.

The port is working fine, it's simply that my computer doesn't recognize that I have my iPhone plugged-in! The phone itself is working (I tested it on my Mac).

I have the latest versions of these programs: hipo, ipod, gtkpod, ifuse, libusmuxd1 and usbmxd.

I connected my iPhone in Windows 7 and it worked, albeit annoyingly. I tried to mount my iPhone with fuse but I got this error:

alvar@alvars-laptop:~$ ifuse /mnt/iphone/
ERROR: the mount point specified does not exist

I have tried the ubuntugeek link, but I got an error while mounting it.

GNUTLS ERROR: A TLS packet with unexpected length was received.

Which one? (I have Lucid not Maverick.)

Which one???

  • I would suggest maybe merging these two questions since essentially the iPad, and iPhone run on the same software and the answer is the same for both. askubuntu.com/questions/26912/how-can-i-sync-an-ipad
    – TheXed
    Commented Feb 19, 2011 at 21:22
  • 1
    that question doesn't help me yet, sorry. my computer doesn't realize that I have my Iphone connected. which is the problem for the moment, what i can do after that is the next step.
    – Alvar
    Commented Feb 19, 2011 at 22:59
  • okey, but now we need to focus at my problem! :) anyone ideas?
    – Alvar
    Commented Feb 21, 2011 at 12:25
  • 1
    You need to create the mount point for it to go, like sudo mkdir /mnt/iphone then try to mount it. Commented Feb 22, 2011 at 15:35
  • aha (me fail) but now I got this error! GNUTLS ERROR: A TLS packet with unexpected length was received.
    – Alvar
    Commented Feb 22, 2011 at 22:57

4 Answers 4


You don't have to jailbreak your Iphone with Ubuntu however you will probably have to add a new "PPA source" to your Ubuntu installation to get the required packages for Ubuntu to Recognise your phone.

The ppa you will need to add is ppa:pmcenery/ppa to add this open a Terminal from the accessories menu and type this at the prompt.

sudo add-apt-repository ppa:pmcenery/ppa

and hit enter once this has been added type this command in the same terminal

sudo apt-get update

and after

sudo apt-get upgrade

this should upgrade your package libimobiledevice to version 1.0.4 from 1.0.1 enabling you to access your Iphone

PPA Reference:


Having had a a good look around for Idevice mounting tutorials I found this at ubuntugeek it goes through the procedure of manually mounting the device including all of the required packages and file edits to get this to work hopefully this is the solution to your problem. Bearing in mind that the tutorial was written for Ubuntu 9.10 and for an Ipod touch there is a quote at the end of the tutorial

Update from our reader :- It works for Iphone 3g. But at the end of preparation procedure you need to restart both your computer and the iPhone device.

Edit 2

if you receive this error message when trying to mount with Ifuse

GNUTLS ERROR: A TLS packet with unexpected length was received

You need to pair the phone with your pc to do this enter this command

idevicepair unpair

Your Iphone or other Idevice will automatically try to re-pair. You can then unplug it and plug it back in and it should mount correctly.

  • I have already installed libimobiledevice! But my computer doen't notice when i plugin my iphone, nothing happens. Which is strange.
    – Alvar
    Commented Feb 19, 2011 at 22:53
  • is it version 1.0.4?
    – Allan
    Commented Feb 19, 2011 at 23:03
  • alvar@alvars-laptop:~$ sudo add-apt-repository ppa:mcenery/ppa Error reading launchpad.net/api/1.0/~mcenery/+archive/ppa: HTTP Error 404: Not Found I am connected to internet so that is not the problem...
    – Alvar
    Commented Feb 19, 2011 at 23:25
  • do you have any 404 messages when you do a sudo apt-get update in terminal?
    – Allan
    Commented Feb 19, 2011 at 23:43
  • 2
    if you can post the output of lsusb (while you have the phone pluged in) you can edit your original question and add it to the end if your phone is listed in narrows the possibility's. At this point it is a process of elimination to deduce the source of the problem the more data you can provide the easier it will be for any one to provide a working solution.
    – Allan
    Commented Feb 20, 2011 at 21:58

The correct ppa is sudo add-apt-repository ppa:pmcenery/ppa as per the Launchpad page.

Try this and let us know how you get on.

  • Thanks Mark didn't notice the typo in the ppa address
    – Allan
    Commented Feb 19, 2011 at 23:55
  • @Allan - no problem, installed as per your recommendation and worked fine for me on Ubuntu 10.10 running my iPhone 3GS with iOS 4.2.1 on Rhythmbox now !! Commented Feb 20, 2011 at 0:00
  • it worked it has been added but i didn't download an update, this might be for that I already have the newest version? I have ubuntu 10.04 64-bits is that a problem?
    – Alvar
    Commented Feb 21, 2011 at 13:52
  • @ Allwar - did you get it to work ok? if so you should accept Allan's answer and add a vote. The version of Ubuntu will not matter. Commented Feb 22, 2011 at 13:26
  • It didn't work I've already said that... And yes I will accept an answer and up vote it when i get one. :)
    – Alvar
    Commented Feb 22, 2011 at 22:54

Try to install these packages and see what happened :

sudo apt-get install hipo ipod gtkpod ifuse libusbmuxd1 usbmuxd

  • I have the latest version of: hipo, libusbmuxd1, usbmuxd. Installing the others, thanks! Sorry it didn't work! :( but thank you for trying.
    – Alvar
    Commented Feb 21, 2011 at 19:07

I had the same problem and almost killed myself from one forum to another trying to find a solution. I installed everything suggested nothing changed.

Actually you do not need to do anything. Just connect your iphone to your computer. Yes nothing will happen. Open F-Spot Photo Manager (Applications/Graphics), click on Import. A window opens asking you to select import source. There you will see your iphone when you click on Select Folder. Choose it and the rest will follow.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .