I am running Ubuntu 12.04. Alt+F1 gets intercepted by Unity (I'm guessing) and highlights the Dash icon. I don't want it to do that, as I want Alt+F1 for other purposes. I have scoured google and tried everything I could find, to no avail. How can I prevent Unity from handling Alt+F1?

  • You seem to be giving up at this point, but if you post some screenshots of what CCSM looks like for you, it might help.
    – Fern Moss
    Mar 24, 2013 at 20:25
  • Thanks, but I'm back on gnome classic, and it's working fine for me. Mar 25, 2013 at 0:47

2 Answers 2


You'll need the CompizConfig Settings Manager (which you can install via the Software Center).

Once open, click on Ubuntu Unity Plugin (in the Desktop section). Under the Behavior tab, you'll see Key to put keyboard-focus on launcher. Simply change the keybinding there.

Note that in later versions of the Unity plugin, the tabs in that plugin have changed (as the comment below by Carlton mentions). The Key to put keyboard-focus on launcher stting is now under the Launcher tab.


CCSM Unity settings

  • 1
    I don't see "Key to put keyboard-focus on launcher" in that app. In any case, CCSM does not have that plugin enabled. Mar 23, 2013 at 2:30
  • Note that there is no checkmark by the Unity Plugin, but it is enabled if you are using Unity 3D (since that's what Unity is, a Compiz plugin). Maybe you are using 2D, though I can't even get CCSM to start in Unity 2D. See here to check: askubuntu.com/questions/62001/am-i-using-unity-or-unity-2d
    – Fern Moss
    Mar 23, 2013 at 17:50
  • 2
    Thanks AibaraIduas, works perfectly although I would add that the option is now in a tab called "Launcher".You can also use the filter to find the option.
    – Carlton
    Jul 3, 2014 at 7:54
  • This works :) and both the question and answer still applies in Ubuntu 16.04. @JackOrenstein: why have you not accepted this answer?
    – Superole
    Sep 18, 2017 at 13:51
  • This is just ridiculous. I'm trying out Unity after many years of using Xfce and I have to say, having to install a program to change a keyboard shortcut is Windows level BS. It even tells you that it's an advanced tool and you may break your system with it. Why the F do I have to use it then for the simplest task? And why do we need more than one place for keyboard shortcut settings?
    – kraxor
    Mar 1, 2018 at 15:06

The above answer works for me on 12.04LTS Unity 3D. If it's not working for you I wonder, are you using Unity 2D? If so you may not be able to change settings with CCSM.

In any case see here for several alternative fixes (the question is for 11.10 but many of these still work in 12.04):

How do I deactivate F1 and F10 keybindings in gnome-terminal?

If CCSM is not working for you, you might try the gconf-editor fix (or alternatively dconf)

Commentary: It's really too bad that this particular keybinding can't be changed simply through the system settings interface, as most others can. I haven't heard that this has been changed in 12.10 but I hope it is in the future. Far too many programs use Alt-keybindings for the OS to make it so difficult to change. (And I'm pretty sure Emacs mapped that keyboard real estate first, Ubuntu.)

  • Hmm, how do I tell if I'm using 2d or 3d? I tried gconf-editor and disabled every use of Alt-F1 I could find. Still no luck. (And I'm exiting X, logging out, logging back in, and starting X each time I tweak something.) I have to say that I'm really hating Unity. E.g., adding an item to the launch bar required a trip to google. Mar 23, 2013 at 14:08
  • Looks like Aibara Iduas commented to provide the link for checking Unity version. But if disabling through gconf-editor didn't work either...hoo, good luck man. Though...just to be sure, are you sure it's the Dash that's being opened? Tapping Alt (without function keys) also opens the HUD in unity. If I'm on the Desktop this does in fact bring up a highlighted Dash icon. If that's the case it's Alt alone that's causing the problem, not Alt-F1. (Same methods for changing the keyboard mapping apply.)
    – nbm
    Mar 23, 2013 at 20:09
  • I'm not sure if it's 2d or 3d. I tried disabling alt. I tried everything in previous comments. I've had it -- I'm back on Gnome Classic, and much happier. Much easier to customize the things I care about, and things just work. Thanks to everyone who helped out with suggestions. Mar 23, 2013 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.