I just installed ubuntu and I really like it, even though the dual-boot configuration took me at least 2 days :p

My dual-boot works fine, except for the fact my windows doesn't boot if one of my external drives is already connected?

Here is my setup: I have an SSD for booting that i split (100gb for windows, 25gb for ubuntu), and I dual-drive with an HDD that I use for storage. I have an uefi-bios and 64x I7 cpu, 16gb ram.

I have 2 external HDD's (for video and back-ups) that I allmost never disconnect.

If I come out GRUB, I can get into ubuntu without any trouble of my ext-HDD. But when I select my win7 and 1 of my HDD's is connected with 1 of my usb-ports, I get a black screen with a text-cursor. I can't type or do anything, only hard reset.

I re-installed my usb-ports, searched for hidden boot.ini in my HDD's, checked my boot-order in BIOS, but nothing works. So the only option is something with GRUB i think? Is there a way to make changes to my usb-boot? Or does anyone now what is holding my windows from booting?

Keep in mind that there is absolutely no problem booting windows if ext-HDD is not connected?

Hope you guys can help me, because I know nothing about ubuntu and GRUB :D

  • So, if an external HDD is connected and you boot into Ubuntu is ok. But if an external HDD is connected and you select Windows 7 in the GRUB, it doesn't work. Is that right? – Lucio Mar 22 '13 at 21:45
  • I believe if you re-install grub with your HD's plugged in it will fix your issue. – Weylin Schreck Mar 22 '13 at 22:41

Try booting into ubuntu and then type sudo update-grub . reset your bios to default from bios setup. Make sure, in your boot order internal HDD/SSD is selected as primary boot option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.