0

I updated to Ubuntu 12.10 using the Update Manager in Ubuntu. ("A new version is available ...") GRUB was broken and I think I managed to fix this but still the Graphical output looks super weired: (The Unity sidebar is lost and I had to start firefox through the terminal [STRG]+[ALT]+[T])

Screenshot of broken GUI

I already tried some apt-get with fglrx, gdm & ubuntu-desktop but nothing changed.

Graphics card: Mobility Radeon HD 2600

  • Please, tell us your Graphics Card model name (HD 4550 for example). – zatloukal-frantisek Mar 22 '13 at 21:01
  • Welcome to Ask Ubuntu! Please provide additional information only by editing your question and not within a comment. Comments might/will eventually be deleted and so your information would get lost. – guntbert Mar 22 '13 at 21:38
0

Your graphics card is no longer officialy supported. You have these options:

a) Use 12.04 with fglrx (precise x and kernel stack)

b) Use 12.10 with OSS drivers

c) Use PPA for 12.10 that enables fglrx installation to 12.10 with old AMD graphics

If you'll choose option c, follow this:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy
sudo reboot

AMD decided to put all its graphics cards without DirectX11 support to "Legacy" state. This means they aren't going to add support for new xserver and linux kernel versions. PPA mentioned above installs git version of xserver, which is fully compatible with legacy fglrx and patched fglrx for compatibility with Quantal Linux kernel.

  • thx, this fixed it. Though am I able to update to 13.04 without problems? – user2084795 Mar 23 '13 at 17:05
  • If you are using that ppa, you should wait (i've looked at it and it doesn't have fglrx-legacy right now). – zatloukal-frantisek Mar 23 '13 at 22:49
  • Jup, I am using the makson96/fglrx ppa. Will this possibly be available anytime? – user2084795 Mar 24 '13 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.