1. I started brasero and chose to copy the dvd to image file.
  2. Brasero reported success.
  3. Playing file in VLC, working flawlessly until unexpected exit at approx. 1 hour 28 mins 20 sec. No error message.
  4. Trying the file in Movie Player. Unexpected exit at the same time, with this message: "An error occured. Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed."
  5. Check that all libraries and ladidah from medibuntu repo are installed. They are.
  6. Repeat steps 1 through 5.
  7. Get the ppa https://launchpad.net/~brandonsnider/+archive/cdrtools and replace wodim with cdrecord and geniosimage with mkisofs.
  8. Throw out brasero and install k3b.
  9. Repeat steps 1 through 5, with k3b not brasero.
  10. Ask forums for help. This question is also posted at ubuntuforums.org.

How come both brasero and k3b reports success and then the iso is obviously broken? How to fix this problem?

This problem is similar, but not identical, to this one: Ripping DVD to iso - Accurately

Thankful for any and all input.

Edit: Tried

dd if=/dev/cdrom of=image_name.iso


ddrescue -v /dev/cdrom image_name.iso

Both of which renders an iso file that is not playing at all. So even though faulty, both brasero and k3b performs better than CLI in this case.

  • for dvd video there is dvdbackup – ustick Apr 26 '18 at 12:21

Maybe the dvd you have is protected by a software lock? try nero too

| improve this answer | |
  • I'd prefer to have it working on free software... – Al F Mar 22 '13 at 9:04
  • 1
    I recommend expanding this to provide information about how to use Nero on Ubuntu. – Eliah Kagan Mar 22 '13 at 9:45

Note that ddrescue makes an encrypted image. If you originally had a non-encrypted image (say from k3b) and you tried to play this in vlc, then the dvd keys for the iso file in your $USER/.dvdcss are for a non-encrypted DVD. If you later use ddrescue to rip a new image, to play it you must remove the old keys for that image in $USER/.dvdcss and then try vlc again.

For problematic disks my best luck is to:

  1. Insert the DVD in the drive
  2. Play the DVD disk with vlc to get the keys into the drive (start to play and just use the bottom location slider to scan through the disk. Do this for all the parts of the disk (main feature and all other parts).
  3. Exit vlc.
  4. Now run ddrescue -- I use (in bash)

    ddrescue -d -r2 -b2048 /dev/sr0 ${NAME}.iso ${NAME}_log
  5. make sure you clear out the dvd keys. In $HOME/.dvdcss each DVD has a directory like movie_name-date_string-disk_key. For encrypted DVDs, The DVD disk has a non-zero disk key, the iso image has a zero disk key, but the contents of the directory are different if the iso image is encrypted or not SO clear out the image dir

    cd $HOME/.dvdcss
    rm -rf ./movie_name-date_string-0000000000
  6. Now run vlc on the ddrescue image and see how you do. This has worked for most DVDs for me. Some are more difficult as it seems there are errors on purpose in the navigation data area of the dvd and you have to let ddrescue work awhile to get enough good sectors in that area.
  7. Note that the encrypted image CANNOT be used to write to DVD media, it can only be played off of the hard drive. (The encrypted disk keys exist in an area that cannot be written by DVD writers)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.