0

How do I get a UDF hard drive partition to mount at boot? From what I can figure, mountall runs before the udf module loads.

Specifically: do PREREQ specifications in initramfs-tools hooks only specify other hooks, or can they specify modules without hooks files? If the answer to this is that they can specify modules I think the solution to the greater problem will be to add a conditional PREREQ to hooks/mountall of udf if the udf module is available.

Currently I have a UDF partition on my hard drive specified in /etc/fstab, and boot hangs with "drive not yet ready or not present". If I specify "nobootfail" in /etc/fstab, the boot completes without mounting the partition. Since the end goal is to have the UDF partition be /home, this is a problem...

  • 1
    UDF filesystems is compatible for fstab settings, AFAIK. Can you make sure you edited fstab correctly. Might as well add it to your question. – oaskamay Mar 22 '13 at 3:24
0

I've found the base problem and a workaround. The problem is that the udf kernel module will not load during the initramfs phase of boot (it's supposed to even by default but doesn't even if explicitly specified); the workaround is to specify option _netdev on the udf filesystem line in fstab.

  • It would have been very helpful to just post your fstab for future visitors (me). Instead of deciphering what you're talking about, I guess I'll just go to the next Google result. – Adam Plocher Jan 5 '17 at 20:01
  • Well, I've basically stopped using udf since then, but here's the basic syntax: /dev/udf /mountpoint udf defaults,_netdev 0 0 – jktrigg Dec 4 '18 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.