I followed this HotTo and changed the package to the newest one AMD offers. It all loaded correctly, but in the end the driver wouldn't run. I see others have success, but as I looked through the comments, I see that someone with an OS and kernel similar to mine couldn't get it working either. Is this a problem with the kernel and porting support, or should I look for something else?


@Alvin, I have a similar problem with my Radeon HD4890 on 12.04 LTS /3.5.0-26. The OpenSource driver is working, but the Card is noisy. I have found this link in askubuntu, but yet not tried by myself (lucky about system is running)


May it helps, good luck!

| improve this answer | |
  • I read it, too. My display still works and has basic functionality (size), but nothing else. I run an ATI HD4350 display card. I may try a couple things on this page later. – alvin Mar 23 '13 at 15:08
  • @Somber Soul, I followed your launchpad-link and it works pretty fine for me. Thanks a lot! – Tim Mar 24 '13 at 16:06
  • I tried this method and got the same result as the original HowTo above, i.e. goes to 'laptop' display with one single resolution available. I have some broken packages and unmet dependencies with xorg. – alvin Mar 26 '13 at 16:46

Try https://launchpad.net/~makson96/+archive/fglrx for Radeon HD 3xxx and 4xxx

| improve this answer | |
  • Thanks for the reply, not sure about adding someones ppa w/o knowing who they are or anything about them. However, this is the type of solution I was looking for and was expecting, just would like it in Canonical supported repos. – alvin Mar 23 '13 at 15:06
  • Understand you) Ok, the problem is with your X-Server version, you need to downgrade it. If you don't wanna use this PPA, you could find other way to do it. X version 1.12 is right what you need. – Somber Soul Mar 24 '13 at 17:26
  • I got your ppa, but it didn't help me yet. I loaded it per your concise instructions and all went well, but I really don't know how to proceed after that. So what I did was go back to the original HowTo above and started with the section following driver removal with this line:./amd-driver-installer-12-4-x86.x86_64.run --extract driver. Then I saw a syntax error on line 4, "wget" where the error said something wrong with the "0" operand like "not found" or "not command" and I didn't know how to go from there so just proceeded down the list and everything else seemed to work, it never loaded – alvin Mar 24 '13 at 19:42
  • Ah, could you send me .logs? Because it's really difficult to understand something what you can't see) – Somber Soul Mar 24 '13 at 23:00
  • I solved this problem on Ubuntu 12.04 and trying to come up with it on Raring Ringtail (beta) right now, and it's really hard, because of kernel version. I passed 12.04 but solution should be same... Try to remove proprietary driver if any and install legacy driver. Make sure you got linux-headers-generic-lts-quantal. Also check out this bug report: bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/993427 – Somber Soul Mar 24 '13 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.