I've got an old Eee PC 701 4G with the following specifications:

  • 512 MB RAM
  • 4GB SSD drive SM223AC
  • 8GB SD card extension
  • Screen resolution: 800 x 480
  • BIOS Revision 1101 (05/16/2008)
  • EC Firmware version: EPC-079

Windows XP SP3 works fine on it, but I decided to switch my OS to Ubuntu.

I have downloaded an Ubuntu 10.10 Netbook Remix ISO and wrote it to my FAT32 SD card using Universal-USB-Installer-, as described on ubuntu.com

  1. During standard load from the SD card the boot process hangs up with black screen.
  2. If I'll press F6 while preloading Ubuntu, it sucessfully displays the boot menu, selecting language and showing 2 main commands: "Run ubuntu from USB drive" and "Install Ubuntu". Selecting either of these commands leading to the same result - after some background work the main loading indicator is displayed ("Ubuntu" text with dotted progress bar under it), and it's progressing forever without any effect.

Is Ubuntu 10.10 compatible with my Eee PC at all? How to boot it correctly?


I am not familiar with this world at all, but I was sick and tired of not being able to load anything on that piece of crap Xandros distro, so this is my first foray into Ubuntu. I had a usb card reader and a micro sd card which I used for the install and had a heck of a time - no matter how I changed the boot order, I couldn't get it to run the trial or anything. Here's how I got it to work - I ejected the SD card, inserted the usb reader, held down the ESC key, and then turned the computer on. Holding down the ESC gave me the option to choose my boot device, whereas nothing else would. Maybe the problem you are having is trying to run it from the SD card slot. Get a card reader and try that! Good luck!

| improve this answer | |
  • 1
    Thanks, Jim. Seems the problem with hanging really was with the built-in card reader. I have found a pen drive and wrote Ubuntu ISO on it using the same method with Universal-USB-Installer, then held Esc key during boot and selected USB device. But the other problem came - Ubuntu loads only in text mode, "startx" command cannot start Gnome. Seems it cannot understand the non-standard resolution 800x480. So I tried a few other distros and have founded EEEbuntu. It works fine, but a little bit outdated (I've got the version of 2008 year), so I'm waiting for Aurora distro to be released. :) – Andrew Feb 24 '11 at 6:18

I had the very same issue as the OP with Lubuntu 18.04 LTS. Symptoms include: when you press Esc while the "Ubuntu text with dotted progress bar" is displayed, you get to the text-mode boot log. There, I would see something like:

[190.934709] sd 2:0:0:0: timing out command, waited 180s 
[190.934709] end_request : I/O error, dev sdc, sector 3970032 
[190.934709] buffer I/O error on device sdc, logical block 496254 

I found the exact same sector and block numbers reported elsewhere, where another user has the same issue of installing on the Asus Eee PC 4G (701). So I thought, these cannot be real block defects on my SD card then, it must be something else. Indeed I was able to successfully boot from the internal SD card reader after the following steps:

  1. In BIOS, set up the SD card reader as the first boot device. For that, you first have to configure it in BIOS as the first mass storage device, and the internal mass storage device as the second one. Because only after that, the card reader will appear in the selection list of possible boot devices when changing the boot order.

  2. In BIOS, set option "OS Installation" to "Finished". I suspect that the alleged block corruption error message happens when this option is set to "Start". The other user with the problem also said he had set this to "Start" when the issue happened.

What I installed was BunsenLabs Linux version Helium / i386, and it's running nicely. For live usage, it was needed to start it with the "Live 586 (failsafe)" option, but with all the no… kernel options removed, as otherwise the touchpad would not work. Once installed, no special kernel options were needed.

Note also that you can use the regular "PAE" version of distributions, no need for a "non-PAE" version, but perhaps for the forcepae kernel option (details).

| improve this answer | |
  • 1
    I just installed this distro I've never heard before (helium-5-i386.hybrid.iso) on my EeePC 701, and it works surprisingly well. Thanks for the tip! – LaurentG Apr 16 at 19:17

Ubuntu 10.10 hang on boot on many asus laptops: read here

| improve this answer | |
  • hmmm... Maybe Asus has some hardware protection from other linux distros except the Xandros? :) – Andrew Feb 26 '11 at 20:55

I had the same problem installing Ubuntu 10.1 Netbook Remix on my Asus EE PC 701 4G using the "USB Universal Installer" from pendrivelinux.com. In my case I was installing it on a 16GB USB drive but it would hang on boot up with the ubuntu boot text prompt before producing the blank screen. I did however have success installing Ubuntu 11.04 using the same installer. It all works fine. Also see this link relating to eee-pc installation of Ubuntu 11.04

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.