6

Problem: I can't adjust the brightness of my iMac and it's killing me. (My eyes! The goggles do nothing!).

Has anyone gotten this to work?

-Booting with rEFIt 0.14

-Product Name: iMac12,2

-Kernel: 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I've tried this fix: https://wiki.ubuntu.com/Kernel/AppleGmuxBacklight

But it doesn't seem to work since the kernel module doesn't seem to be loading. (dmesg | grep gmux returns nothing)

I've also tried doing this:

xrandr --output LVDS --brightness 0.3

and it dims the screen, but the mouse cursor still blazes away at full brightness.

Any thoughts? Thanks!

UPDATE:

Performing ls /sys/class/backlight/ returns acpi_video0

-The brightness slider in "System Settings" has no effect.

-The "brightness" function keys on my apple bluetooth keyboard don't have any effect.

Thanks!

3
  • Can you ls /sys/class/backlight/ – Symin Mar 21 '13 at 18:16
  • If I perform that, I get: acpi_video0 That's it. – PopeJamal Mar 21 '13 at 22:00
  • You are not using external monitor, right? – Symin Mar 22 '13 at 19:08
1

Have you tried adjusting the acpi_video0 with a terminal?

To check max value you can use run:

cat /sys/class/backlight/acpi_video0

To check current brightness:

cat /sys/class/backlight/acpi_video0/brightness

To change brightness (input between 0 and your max_brightness):

echo YOUR_BRIGHTNESS_HERE | sudo tee /sys/class/backlight/acpi_video0/brightness

If this doesn't work perhaps your bootloader is messing something up or this video driver doesn't work on your machine.

0

Right,

I don't know if you tried this, but:

  1. You could use the FN keys

or,

  1. Just edit the brightness in System Settings!

Hope this helps!!

0

I have never used this gmux thing, but it looks like it is a dynamic kernel module. Are you sure you didn't have any errors while installing it?

Remove the module:

sudo modprobe -r apple_gmux

Uninstall it:

sudo apt-get remove apple-gmux-dkms --purge

Run update:

sudo apt-get update

Check your kernel version:

uname -a

e.g

Linux MarsBox 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Make sure the kernel headers are installed for your kernel

sudo apt-get install linux-headers-3.5.0-26-generic

Install the gmux again

sudo apt-get install apple-gmux-dkms

Enable module

sudo modprobe apple_gmux

Check if it works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.