I've just discovered Tomboy and like it. I added it to the startup applications, and on next boot Tomboy won't start. It then also won't start when I select it manually from the menu.

  • I unchecked its entry in the startup applications and rebooted, but it still won't start.
  • I uninstalled it and installed it again in order to perhaps fix some broken file or setting, but it didn't help.
  • I saw this question and added the Applet. But the applet says "Tomboy Notes" has quit unexpectedly and a reload doesn't work; the message appears again.
  • starting it from terminal gives this error report.
  • When I enter ls the note file, I get -rw-r--r-- 1 torben torben 0 2011-02-17 09:09 /home/torben/.local/share/tomboy/f3370271-6210-4b78-8b4a-c31cc2af6935.note

How can I fix what's wrong?

  • Try starting tomboy from a terminal (e.g., gnome-terminal, or xterm). See if any interesting errors pop up. Tomboy relies on mono, so if there are failures in mono, you'll have issues with tomboy as well. – belacqua Feb 19 '11 at 7:34
  • What a great and simple idea! I've added the result above. – Torben Gundtofte-Bruun Feb 19 '11 at 7:38
  • 1
    What does ls -l /home/torben/.local/share/tomboy/f3370271-6210-4b78-8b4a-c31cc2af6935.note show? – user unknown Feb 19 '11 at 7:50
  • Looks like it might be blowing up on accessing the directory or the file, so an ls is a good place to start . – belacqua Feb 19 '11 at 7:52
  • Thanks! ls result posted in the question. – Torben Gundtofte-Bruun Feb 19 '11 at 8:59

It appears that note is corrupted, try moving it:

mv /home/torben/.local/share/tomboy/f3370271-6210-4b78-8b4a-c31cc2af6935.note ~/Desktop

and then start Tomboy again.

  • Yep, that worked! I moved all notes to the desktop and then Tomboy could start. I quit it and moved one note back, then started Tomboy again. Quit, repeat. Only one note is broken - and that's the only one I have!! The other 3 are the built-in samples. Is there no way to recover that note?? It's my Ubuntu installation diary.... ironic, isn't it! – Torben Gundtofte-Bruun Feb 19 '11 at 19:00
  • I tried to open the note in gedit; it said Unexpected error: Error opening file: Input/output error ... – Torben Gundtofte-Bruun Feb 19 '11 at 19:01
  • @torbengb The gedit error is consistent with the note being corrupted, unfortunately. My notes get corrupted fairly often -- probably worth making regular backups. – Amanda May 10 '11 at 16:22
  • Thanks. I stopped using Tomboy after that early crash. I'm now only using (n-)Evernote. – Torben Gundtofte-Bruun May 10 '11 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.