I was trying to use the latest Pencil (version 2.0.3) in Ubuntu 12.04, but the PNG exporting does not work, with Pencil working both inside and outside Firefox (which is 19.0.2).

The export page as PNG dialog asks for where to put the file but fails silently after that, and the export document using any HTML template gets you this dialog stalled forever:

enter image description here

How can I fix it?

  • 2
    To whoever voted to close this: do you care to comment? I really fail to see why this question is inappropriate here.
    – elias
    Mar 21, 2013 at 16:19
  • 1
    While I am not the person who voted, that vote is an off-topic vote. That usually means they think this is a bug.
    – Seth
    Mar 24, 2013 at 3:18
  • @Seth oh, I see... Thanks! Well, I understand that bug reports aren't really appropriated here, but this is not really a report: it's an explanation on how to apply a workaround. I fail to see why this is inappropriated.
    – elias
    Mar 24, 2013 at 16:32
  • 1
    Yes I see that. Looks good to me. The vote should eventually expire anyway.
    – Seth
    Mar 24, 2013 at 17:05

3 Answers 3


UPDATE: Before trying this workaround, you may want to try the latest version provided by this community fork: https://github.com/prikhi/pencil/releases

This is a bug filed several times, and a workaround is available at: http://code.google.com/p/evoluspencil/issues/detail?id=170

The workaround is to use plain xulrunner to run Pencil instead of Firefox, then the problem disappears. You can download xulrunner from here, extract it somewhere and use it to run Pencil like this:

xulrunner --app /usr/share/pencil/application.ini --no-remote

The --no-remote is for xulrunner not to try to reuse an existing Firefox instance running. You may need to change the path to pencil's application.ini, depending how you have it installed.

If you have installed Pencil with the official .deb provided by Evolus here, you can follow these quick steps:

  1. Open a terminal and turn into root:

    sudo -i

  2. Then, download xulrunner (17Mb) and extract into /opt:

    wget -O - http://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/16.0.2/runtimes/xulrunner-16.0.2.en-US.linux-x86_64.tar.bz2 | tar xjf - -C /opt

  3. Change the Pencil executable script to run with xulrunner instead of Firefox:

    sed -i '/application.ini/ { s|^/usr/bin/firefox|/opt/xulrunner/xulrunner|; s/$/ --no-remote/; }' /usr/bin/pencil

  • tnx work fine (Ubuntu 13.04 x64)
    – JoZ3
    Jul 11, 2013 at 23:16
  • Works perfect for me as I had this issue in Ubuntu 14.04 LTS. Jun 5, 2015 at 11:00
  • Unfortunately, this didn't work for me with the latest 2.0.5 xpi - it worked as plugin in Firefox 39, but not as standalone; to get the standalone, I had to use the fork github.com/prikhi/pencil, do the ./build.sh linux, and then /path/to/firefox --app Outputs/Linux/application.ini --console --no-shared from the same, build directory - that both ran, and did the export correctly.
    – sdaau
    Jul 29, 2015 at 13:31
  • Works in 14.04 Ubuntu 64 bit. It is important to use the version 16.0.2 of xulrunner, trying to download the latest will not resolve the isssue
    – vumaasha
    Sep 27, 2015 at 10:36

I ran into the same issue. If you don't mind going down one minor version to 2.0.2 it's packaged with xulrunner as part of the deb, which will resolve this particular issue.




The Pencil project is on GitHub now https://github.com/prikhi/pencil

Find the latest releases here: https://github.com/prikhi/pencil/releases

Upgrading to the latest (v2.0.13 when writing this) fixed the issue for me.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .