I'm trying to mount a Nokia 620 phone running Win8 on my Ubuntu 12.10 box. I can see the device using lsusb, but from what I can see it's not listed under sudo blkid. I'm trying to follow the instructions here: https://help.ubuntu.com/community/Mount/USB

Has anyone done this successfully?

Just for clarity, I want to be able to copy files from my computer onto the phone.

I've tried using a Win8 image on Virtualbox - no luck. I have all USB devices enabled for the virtual machine.

  • I think, wp devices are like apple devices. You need Zune to do all that. – Web-E Mar 26 '13 at 11:33
  • Windows Phone 8 mounts just as storage, no Zune required (on Win PC) – 451F Jun 13 '13 at 9:17
  • After upgrading to Raring and updating my phone with the latest updates from Nokia, this now mounts as a removable drive (including the removable storage) using MTP. You may need to install the MTP drivers as per Web-E's answer, but try both of these first. – Aaron Newton Oct 10 '13 at 3:32

I don't own any wp devices. So this answer goes in kind of assumption and internet research. Anyone wants to correct any information, please do so.

Windows Phone 8 only Support MTP and has no Native Mass Storage Support. But you said, it is not even detected on Windows 8 , that is a bit confusing.

However, since Windows phone uses MTP, so only we need update the MTP library.

While searching on internet, I found out a blog that talks about it, and he can mount it. But on Mac . You can look here

So, for ubuntu, I would suggest to give a try to updated GVFS with MTP support. The article was written for Android 4.0+ devices which doesn't support Mass storage but only support MTP. You can have a look and instruction here. They talk about updating the MTP library.

But, interesting thing is, they have added a note on Feb 13, 2013. with a list of devices that are supported in the unstable PPA. And Lumia 920 is there. So it might be possible, it will be working with 620. If not you have to wait.

So I would suggest,

  • add ppa ppa:langdalepl/gvfs-mtp & install all available update.

  • Reboot, unlock your device and connect. See if it is now on Nautilus.

  • If not, add this unstable ppa ppa:webupd8team/unstable & avail the updates. There should be one update, libmtp. Install, reboot and retry.

  • The downgrade info is there on webup8 site. Remove unstable ppa first and then gvfs-mtp

  • No luck so far, but thank you for putting me onto MTP - I'm investigating this now. – Aaron Newton Mar 27 '13 at 12:29
  • I just received a Lumia 620 yesterday and had trouble to get it to work with 13.10 (the PPA hasn't been updated until now). I documented my troubleshooting in a bug report linked in my answer askubuntu.com/questions/87667/… – LiveWireBT Nov 3 '13 at 12:50

My neighbor used this guide to do pretty much the same thing..... Hope it helps! Nokia

  • Thank you for that. I've tried this - it gives me an empty Obex utility window. This is most likely wrong (or at least not quite what I want) since I know I have files on the storage of the phone. – Aaron Newton Mar 26 '13 at 11:11
  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eliah Kagan Mar 26 '13 at 11:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.