I'm running Ubuntu 12.10

  • Intel i5
  • 8Gb
  • 1TB
  • Gigabyte MB

I have backed up all my data(Home folder only) to an external HDD. Today, after a fresh OS install with the same version of Ubuntu, I can't restore my data.

The following error comes up every time I have also tried command line:

duplicity --gio file:///media/backup /tmp/restore

same error

raceback (most recent call last):
  File "/usr/bin/duplicity", line 1412, in <module>
  File "/usr/bin/duplicity", line 1405, in with_tempdir
  File "/usr/bin/duplicity", line 1339, in main
  File "/usr/bin/duplicity", line 630, in restore
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 522, in Write_ROPaths
    for ropath in rop_iter:
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 495, in integrate_patch_iters
    final_ropath = patch_seq2ropath( normalize_ps( patch_seq ) )
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 462, in patch_seq2ropath
    assert first.difftype != "diff", patch_seq
AssertionError: [(('home', 'harry', '.apport-ignore.xml') reg)]

Please help.


I'm on Ubuntu 12.04 and had trouble restoring a backup with either Deja-Dup or Duplicity. After two days of research and trial and error I would recommend the following steps (jump to Step 4 if you want a quick restore solution but bear in mind that the problems will be back withtout Steps 1-3):

Step 1: Try to restore your backup via Terminal with Duplicity.

  1. If Deja Dup gives errors, open Terminal and try

    duplicity --gio file:///media/backup /tmp/restore
  2. Be sure to use file:/// because Duplicity expects a URL.
  3. That didn't work? Check if Duplicity has got a problem by running a test script from Launchpad, found here: https://bugs.launchpad.net/duplicity/+bug/1252484. Direct Link: https://bugs.launchpad.net/duplicity/+bug/1252484/comments/10.

Step 2: Fix Duplicity error(s) by upgrading to proposed version if necessary:

  1. Enable Proposed Repository here: Applications→Ubuntu Software Center→Edit→Software Sources→Updates. Do NOT update your system now because proposed repo is beta!
  2. Upgrade Duplicity only with these commands (replace /precise with your Ubuntu version name). More info at https://wiki.ubuntu.com/Testing/EnableProposed:

    sudo apt-get update
    sudo apt-get install duplicity/precise-proposed
  3. Disable proposed repository!

  4. Reboot and run test script again. Error should be gone!

Step 3: Check for other errors in Duplicity.

  1. Run Duplicity again in verbose mode (you will probably still get errors):

    duplicity -v9 --gio file:///media/backup /tmp/restore
  2. Check for the following error at the start of your terminal output:

    Import of duplicity.backends.sshbackend Failed: No module named paramiko 
  3. If you find that error install another package (Found here: http://www.rubenortiz.es/2012/12/11/ubuntu-no-module-named-paramiko/):

    apt-get install  python-paramiko

Step 4: Find and fix Deja Dup problem.

  1. Run duplicity in terminal again:

    duplicity -v9 --gio file:///media/backup /tmp/restore
  2. You will still have the AssertionError & the log tells you that some parts of your backup will be skipped because the are not accepted by duplicity.
  3. Navigate into your backup folder.
  4. Locate files that are named similar to this: duplicity-full-signatures.20130523T142126Z.sigtar.gz.
  5. Move all except one of these files out of the backup folder to a safe place.
  6. Try Duplicity command again. It should work now.
  7. If it doesn't work yet, try out with different sig-files.
  8. Try Deja Dup again. It should work now.

In the unfixed version Duplicity creates duplicate signature-files that lead to broken restore. I don't know which of the signature-files have to be preserved so trial an error! Info found here: https://bugs.launchpad.net/ubuntu/+source/duplicity/+bug/633101 and here: https://bugs.launchpad.net/duplicity/+bug/703142.

Sidenote: I wasn't able to upgrade Deja Dup to recent stable version. It just stayed on v22, so maybe there is a problem, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.