I was attempting to install VMware Player through the terminal using these codes:

sudo apt-get install build-essential linux-headers-uname -r

mkdir ~/VMware && cd ~/VMware

wget -c http://goo.gl/qGcHF -O VMware-Player-5.0.1-894247.i386.bundle.tar

tar -xvf VMware-Player-5.0.1-894247.i386.bundle.tar

chmod +x VMware-Player-5.0.1-894247.i386.bundle

sudo sh VMware-Player-5.0.1-894247.i386.bundle

I get more than one error:

E: Unable to locate package linux-headers-uname-r

So I tried the second part, just hoping it'd work. And I get:

wget: unable to resolve host address 'vmware-player-5.0.1-894247.i386.bundle.tar'

I checked all the commands, all the spelling, all the numbers, everything. Went to several different guides and it all says to do the same thing, and I always get the same error.

Help. Please. I need it for my programming class. ;-;

EDIT: host address http://goo.gl/qGcHF was not found, after fixing the backtick issue. Except the .tar was apparently in the directory. tar -xvf did not work. Changed it to tar -xf

sudo apt-get install build-essential linux-headers-'uname -r' [Backticks ` instead of ']

mkdir ~/VMware && cd ~/VMware

wget -c http://goo.gl/qGcHF -O VMware-Player-5.0.1-894247.i386.bundle.tar [host address not found, but .tar was in directory?]

tar -xf VMware-Player-5.0.1-894247.i386.bundle.tar

chmod +x VMware-Player-5.0.1-894247.i386.bundle

sudo sh VMware-Player-5.0.1-894247.i386.bundle

  • There is a space between uname and -r (This is a common feature of all commands; the letters after the - are known as "flags", they allow you to use optional features). Also, Linux does not show your password as you type it. – Gary Mar 21 '13 at 1:52
  • I know. I was typing it and pressing enter, and nothing would happen. Fixed with a restart of the terminal. Then I typed it exactly as I have been, with the replacement of ' with ` and it worked. Thank you, though. =3 Now to try the rest of it. EDIT: However the host address still can't be found. Except it's apparently in the directory. So hopefully the other commands will work. – Justice2497 Mar 21 '13 at 1:57
  • If you have the tarball (the .tar) everything should be good to go! But keep in mind if wget gives you issues you can always simply visit that link in a browser and it will download to ~/Downloads. – Gary Mar 21 '13 at 2:13
  • It worked, had to change the -xvf to -xf though. Lol. All those guides had -xvf and I thought something look a bit off there. Currently installing, thank you! I love Linux, it's easy to use, and when you have issues, lots of nice people out there that can and will give you directions. =D – Justice2497 Mar 21 '13 at 2:24
  • By the by, the -v that you removed only means verbose (that is usually common across many commands) so in the case of tar it prints the names of the files it is working with. It should not affect the outcome whether you have it or not. That's great that you have it installing though, and yes, Linux is a wonderful thing! – Gary Mar 21 '13 at 2:30

You are missing the back tics around the

`uname -r` 

The result should look something like linux-headers-3.2.0-38-generic-pae, Or you could just look at the output of uname -r and type in the result yourself.

  • The odd thing is, it actually looks like he does have the back tics in his question...or is the two-tone of the code block around uname -r not an artifact of "nested code" (because the code blocks use back tics as well)? Which is then made more confusing by the fact that the outpt of apt-get clearly shows that the back tics were forgotten. – Gary Mar 21 '13 at 1:39
  • LOL I was using the regular ' because I was an idiot and didn't realize they were backticks. I'm an idiot sometimes. Well. Let's go see how that works. Thanks,ubfan. =3 – Justice2497 Mar 21 '13 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.