I recently got a new laptop and I've just installed Ubuntu 12.04 on it. I went to transfer files over from my old laptop using my external hard drive and closed the lid when I went away, forgetting I hadn't changed the power settings to do nothing when the lid is closed, so the laptop suspended.

When I reopened the lid, later on, I realised this and got errors that the folders could not be transferred anymore as they did not exist.

My external harddrive is no longer powering up. Is this normal? Can it be fixed?


This is the result of the ( brain-damaged imho ) way Linux handles USB disks during suspend. It can't be sure that you didn't unplug the disk, plug it into another computer, modify it, and plug it back in to this one while it was suspended, so it just assumes you did unplug the drive, and breaks the mount point.

You'll have to make sure the drive is unmounted ( a reboot will be sure to do the trick ), and then plug the drive back in, and fsck it. You can do this with either the gnome-disk-utility or gparted.

  • There was nothing to unmount. as far as ubuntu was concerned there was no device to unmount. I did a system restart and there's still no device to mount, even in gparted. The harddrive is plugged in both at the mains and the USB. but it only starts up usually when it's plugged in to the computer. It's plugged in but it seems like it's not on. No power being sent to it by the computer. Dunno what to do. Any other suggestions? – Adam Mar 20 '13 at 17:15
  • 1
    @Adam, run tail -f /var/log/syslog and unplug, and replug the drive and see if anything shows up. – psusi Mar 21 '13 at 13:04
  • Nah, nothing showed up. In the end I opened up the external harddrive case and took the harddrive out and connected it to another. I knew it wasn't the cable that was the problem nor the power cable as I had tried others I knew worked. So it was my last hope. Now it works... The power wasn't getting to it. So dunno if it was a coincidence that it broke when I suspended it or...but now I'm obviously scared to suspend the laptop again so I disabled the option. – Adam Mar 23 '13 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.