When I try to print a PDF file that contains images, the printing stops just before the first page that contains an image. If the first page contains an image, only a single blank page is printed.

I saw that there is an old bug report, relating to Ubuntu 11: https://bugs.launchpad.net/ubuntu/+source/cups-pdf/+bug/836278

However, I have 12.04, and I updated cups-pdf, and I still get this error.

  • Can you plz check whether cups-pdf on your system is >= 2.5.1-6? Also, have you upgraded your system from < 12.04, or installed 12.04 from scratch? – nutty about natty Mar 20 '13 at 9:25
  • Do you experience the problem when trying to print a pdf file out on paper? Or are you trying to "print to pdf" (print-to-file)? Or both? – nutty about natty Mar 20 '13 at 9:28
  • apt-get tells me that "cups-pdf is already the newest version." How can I check what version it is? I work on a fresh 12.04 install. I experience the problem only when trying to print a pdf on paper. – Erel Segal-Halevi Mar 20 '13 at 11:20
  • hmm, I'd use synaptic to check the version. If it's a clean install, I'm not sure if purging will help -- but neither should it harm. – nutty about natty Mar 20 '13 at 11:23
  • Or, type apt-cache policy cups-pdf in a terminal and hit enter. I see "cups-pdf: // Installed: (none) // Candidate: 2.6.1-7 // Version table: // 2.6.1-7 0 // 500 archive.ubuntu.com/ubuntu quantal/universe i386 Packages". – user25656 Mar 20 '13 at 12:10

A workaround that worked for me

I installed first (I did not had it installed):

sudo apt-get install cups-pdf

Then I printed the PDF from Evince using the new PDF printer that is added by cups-pdf first. The output goes to ~/PDF (can be configured in /etc/cups/cups-pdf.conf).

Then I opened the pdf file generated by cups-pdf printer to Evince and printed it again to my real printer.

It worked.

  • I printed from Evince but, the output file (which I indeed found in ~/PDF) did not contain the pages with the images... – Erel Segal-Halevi Jan 19 '14 at 7:41
  • But, the idea of printing to PDF is useful in itself - it allows to check the problem without wasting paper. – Erel Segal-Halevi Jan 19 '14 at 7:43

Perhaps try to

  • purge cups-pdf (in synaptic, "mark for complete removal");
  • then re-install cups-pdf.

I have similar issue that print a blank PDF file. Purge then re- install fixed my problem.

sudo apt-get purge cups-pdf
sudo apt-get install cups-pdf
sudo /etc/init.d/cups restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.