Attempted to add the Matlab installation and it asked me where my current installation was -- never have tried to install it before -- I hit cancel when it asked for the installation directory and now Ububtu Software Center bogs down the machine and everything in line to download and install behind it in the queue is hosed.
No places to hit pause or cancel for any of the line items. Just says "Applying Updates" and is in the list no matter what (I already closed out USC and restarted the machine several times). How should I proceed to get this out of the way? Is it an USC specific problem or an installation script problem? TIA

@dobey: I do not have matlab installed -- I was shopping on the USC, saw the matlab icon, tried to download the package. "Bogs down the machine" as in USC pulls 22% usage all by itself and the rest of the system suffers. The package is in limbo because it does not show as installed nor in history, so how do I kill the package from my USC download list?

@Daniel Llewellyn

Both commands say the same thing at the end: 1 not fully installed or removed debconf: DbDriver "config" /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

dpkg: error processing man-DB (--configure): sun process installed post-installation script returned error exit status 1

No apport report written because MaxRrports is reached already

Errors were encountered while processing: man-db

E: Sub-process /usr/bin/dpkg returned an error code (1)

  • How did you install matlab exactly? Where did you get it? Did it not finish installing? What does "bogs down the machine" mean exactly? Please update your question with the information to answer these questions. – dobey Mar 19 '13 at 14:08

Finally cleared it out after I noticed trying to install anything made the DbDriver complain and /opt subdirectories show a locked file -- went to the command line and installed synaptic which located the hung matlab install (after update and upgrade). Synaptic solved it behind the scenes. Hope that helps anyone else who runs into this issue in the future...


This sounds like the package is stuck mid-install.

From the commandline run sudo apt-get -f install to see if it clears the queue.

Once the queue is cleared, if you don't want matlab you can remove it again as normal: sudo apt-get remove matlab.

Doing this in the commandline may give you useful diagnostics information if things go pear-shaped again. (Usually a botched install will leave a log-file behind which lists every action it performed, and which action failed causing the early exit and the inconsistent state of apt.)

Not the answer you're looking for? Browse other questions tagged or ask your own question.