I want to move content of a directory within another directory with the same folders.

Here's an example:

I have ./backup which has the directories base and test. Now, I want to move these directories to ./backupArchives.

I use this:

mv ./backup/* ./backupArchives

but I got the error

mv: cannot move './backup/base' to './backupsArchive/base': Directory not empty

I tried using --force, but no luck. Is there a way to move it when folders already exists?

Note: I just want to merge contents, there's no overwriting.

  • Are you just trying to merge the folders' contents into the destination, or are you trying to overwrite what's in the destination. (it also helps if you have the ENTIRE error, without using ...... to truncate data)
    – Thomas Ward
    Mar 19, 2013 at 4:13
  • 1
    I just want to merge the contents, there's no overwriting.
    – UdK
    Mar 19, 2013 at 4:20
  • 2
    @UdK Even if this would work, note that this would not merge the contents of the two directories. Moving a directory will replace its target. Have a look at rsync instead, it will do the merging.
    – zwets
    Mar 19, 2013 at 7:38
  • I got into the same situation, i was doing mv <folder_name> ~/ from the downloads directory and was getting the error as: mv: cannot move '<folder_name>/' to '/home/user/<folder_name>': Directory not empty but when i did mv <folder_name> ~/home/, it worked, Didn't understand what solved the problem here though.
    – y_159
    Sep 27, 2021 at 15:22

7 Answers 7


Though its man page doesn't document it, mv will refuse to rename a directory to another directory if the target directory contains files. This is a good thing in your case because you turn out to want to merge the content of the source into the target, which mv will not do.

Use rsync -a backup/ backupArchives/ instead. After that rm -rf backup/*.

Instead of using rsync, you also can do the classical

(cd backup && tar c .) | (cd backupArchives && tar xf -)

which earns you more geek points.

  • 5
    nice things to know! Both are working great. Thank's!
    – UdK
    Mar 20, 2013 at 17:54
  • 2
    should be noted this requires you have the size of the folder in free space. And will cause horrible problems if not.
    – Pogrindis
    Oct 2, 2014 at 21:07
  • 4
    @Pogrindis Please explain what horrible problems will occur, and how they are different from any other attempt to write to a full disk? Indeed, since both operations keep the original directory intact, if the operation fails you simply rm -rf backupArchives without consequences, let alone 'horrible' ones.
    – zwets
    Oct 5, 2014 at 9:15
  • 3
    you can use rsync's --remove-source-files option instead of removing the folder with "rm -rf backup/*" command.
    – eaykin
    Feb 24, 2015 at 16:11
  • 5
    Thanks for naming the classical approach, very helpful if rsync is not available! Also works with sudo using sudo sh -c '(cd backup && tar c .) | (cd backupArchives && tar xf -)'
    – ArendE
    Jun 23, 2015 at 23:11

Quick and dirty, if you know what you are doing:

cp -r ./backup/* ./backupArchives && rm -R ./backup/*
  • 3
    Also works in my safe mode, genious. Dec 23, 2014 at 18:08
  • 1
    If you need to preserve permissions and last modified time, then add --preserve May 19, 2020 at 18:16
  • I get 'p: invalid option -- '. My cp seems to be broken.
    – Timo
    Jan 25, 2021 at 15:11

After the directory you moving you need * (represents any text or number). For example:

mv /var/www/* /recovery/wwwrecovery/

thats all, if you moving files, than you move as:

mv /var/www/index.php /recovery/index.php

Another way is to pack that folder content by using tar:

tar -cvzpf backup.tar.gz /var/www 

Then move it lie any other file. Also I recommend this step because tar compresses it and make it smaller in size.

To extract the files to another folder use

tar -xvzpf /var/www/

If you need to copy to a location you don't own, make sure to prepend your command with the sudo command after whichever option you decide to use.

sudo tar -cvzpf backup.tar.gz /var/www/
  • I'm using Ubuntu 12.10 and I got: mv: invalid option -- 'R' Try `mv --help' for more information. Indeed .tar is nice, but I need to know how to move my files for this situation. Thank's for your help
    – UdK
    Mar 19, 2013 at 4:34
  • i using 12.04 desktop and server and in both works well. be carefull, if you didnt make space betwen folfer and -R. i also tryed without -R works in same way for me, try without -R, but be carefull with spelling: linux matters lower and uppercase letters!!! than if path is incorect movingin or movingfrom location. if you dont have that folder that you wana move to just put -C after it and it will create it. also try first: find -iname name of your folder and run this command from root, just to see if it exists in other place if you miss spelled something. give me exact command that you used Mar 19, 2013 at 4:47
  • what thaaa..... put that filename in betwen ** Mar 19, 2013 at 4:54
  • 2
    That -R surely shouldn't come after the first argument. Options (nearly) always precede the command arguments. Also, mv has no -R option, and finally, recursion is irrelevant to a mv. @DimitrisTheodoridis please test your answer first.
    – zwets
    Mar 19, 2013 at 7:34
  • 1
    yes my bro you are right, i always have problems with my spelling, and allways i have problem with terminal for that or command not found or create new files and directories that i dont know, just for bas spelling... by the way i used cp command, than here wrote mv sory for that bro :D Mar 19, 2013 at 17:23

Sure rsync does work, but this might work as well for machine that does not support rsync (i.e in cpanel, which rsync is not installed by default).

What about using:

cd /path/to/backup/ && cp -R --parents ./* ../backupArchives

Then remove the backup directory if necessary

Note1: You need to cd to the backup directory before executing the cp -R --parents ...

Note2: Double check the backupArchives directory if you got the new files from backup.


I had to copy a very large directory with a lot of large files, so I created hardlinks to the original files in the target directory like this:

cp -al ./backup/* ./backupArchives

Then I deleted the originals, leaving only one hardlink to each file.

Since hardlinks are quite space efficient, you could even use hardlinks to copy the backupArchives and backup directories to a new trial location, and check that the file counts are as you expect, as a dummy run. This assumes that your filesystem supports hardlinks - ext4 does.


Before asking the question, let's consider a simplified case.

Suppose in /home/admin we have two folders foo and bar which have the same subdirectory structure, but each contains different files in it. Now we want to merge them into one. When we do things like mv foo/* bar, the error mv: directory not empty occurs.

My solution is to give up command line tools and switch to a GUI file manager, for example, dolphin. When you rename foo to bar in dolphin, it gives you the option to write into the destination folder, and asks you whether to overwrite existing files, interactively. This avoids copy and delete, which in effect saves your time without a single line of code.

PS: I didn't test every file manager out there. But most of them should have this feature.


When moving directory during a script execution, you need to consider non-existing or empty directories, and also force override and removal without confirmation:

# If old directory exists, and isn't empty
if [[ -d old_dir ]] && [[ -n `ls -A old_dir` ]] ; then

  # Make a new directory (skip if already exists)
  mkdir -p new_dir

  # Copy all files to the new directory (-afr : Keep attributes, Force overwrite, Recursive copy)
  cp -afr old_dir/* new_dir/

  # Remove old directory
  rm -rf old_dir

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.