4

Tried installing Consolas on Ubuntu 12.04 as suggested here but the font is not visible in the settings of IntelliJ Idea CE IDE.

[Edit 1]

I also copied the font to /usr/lib/jvm/jdk1.6.0_30/jre/lib/fonts and did sudo fc-cache. Now the font is visible in Gedit but is still not visible in IntelliJ Idea and it not visible in Libre Office3.

Appreciate help.

  • Does it help if you place Consolas.ttf files into JDK_HOME/jre/lib/fonts directory for the JDK installation that is used to run IntelliJ IDEA? – CrazyCoder Mar 19 '13 at 22:37
  • @CrazyCoder There is only one JDK installation (Sun JAVA) and that is used to run IntelliJ Idea. – Gaurav Agarwal Mar 19 '13 at 22:43
  • 1
    Did you copy all 4 files? consolaz.ttf, consolai.ttf, consolab.ttf, consola.ttf. I just tried it, copied these files from Windows machine to the jre/lib/fonts and IDEA sees the Consolas font. – CrazyCoder Mar 19 '13 at 22:53
  • @CrazyCoder No, I will copy all the file now and retry. Which version of Ubuntu did you tried on? – Gaurav Agarwal Mar 19 '13 at 22:56
  • Ubuntu 12.10, OS version doesn't matter here. I'm running under JDK 1.7, but it will also work on 1.6. – CrazyCoder Mar 19 '13 at 22:59
3

Consolas font is not just one file, you need to copy all 4 font files into JDK_HOME/jre/lib/fonts:

  • consolaz.ttf
  • consolai.ttf
  • consolab.ttf
  • consola.ttf

Then the font works just fine:

Consolas works!

| improve this answer | |
  • 1
    I copied them (those 4 files) from a Windows machine's "Windows/Fonts/" folder and installed using "Font Manager" on Ubuntu, don't forget to restart IntelliJ. – Kerem Aug 22 '14 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.