So basically X can't start on my Macbook mid 2010 running the Geforce 320M after installing the geforce driver.

It never really came up properly even out of the box, though the Live version seemed to work fine before I installed.

After it didn't startup properly, I went to the terminal and did an apt-get upgrade. Then I ran apt-get install nvidia-current-updates and ran the command

apt-get install linux-headers-`uname -r`
which I found worked for someone else here to get the driver going.

This hasn't worked for me. The driver appears to be installed fine but upon restart it just hangs before getting to launch an X server. I rebooted to a root terminal and checked /var/log/Xorg.0.log and found the following.


So fine, I found this online to resolve this issue: nvidia-xconfig which generates a default xorg.conf file at /etc/X11/

But now I have a new issue. When I boot, it gets stuck with this output on the screen: brcms_ops_info_changed: arp:filtering: enabled true count (0) (implement) brcms_ops_info_changed: qos enabled: false (implement) brcms_ops_info_changed: arp filtering: enabled true count (0) (implement)

I still get the failed initialisation of screen error above.

When I open the xorg.conf generated by nvidia-xconfig command, I can see the following:


I have dmesg output but you need more than 2 rep to post: pastebin.com/DL6FxTwE


The nvidia driver works in BIOS compatibility mode, but not EFI mode.

If you want to boot in BIOS compatibility mode you can either:

  1. Download the 'amd64+mac' version of Ubuntu (from cdimage.ubuntu.com/releases/)

  2. Switch from grub-efi to grub-pc.

I've posted my xorg.conf file, which works in BIOS compatibility mode.


  • After a failed memory stick issue that caused mass confusion, I got around to doing this :P I just downloaded amd64+mac, I tried switching to grub-pc from grub-efi but I think I did it wrong... So full steps were: Preliminary step, install rEFIt using the standard installer 1) Download and install amd64+mac Ubuntu Desktop. 2) run sudo apt-get install linux-headers-generic 3) run sudo apt-get install linux-headers-uname -r 4) run sudo apt-get install nvidia-current-updates 5) restart
    – brim4brim
    Apr 14 '13 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.