I have an Acer Aspire S3 running Linux Mint 14 / Ubuntu 12.10. The problem with my wireless is that it keeps disconnecting from the Internet for about 1 minute at a time. It does this every 5-10 minutes. It is still connected to the router - I can ping my router, but I cannot ping an outside server.

I disabled Dnsmasq by commenting out a line in /etc/NetworkManager/NetworkManager.conf and switched to Google's DNS servers. This definitely made things better, but it makes me wonder if maybe doing that sovled an earlier DNS problem and that now I have a different problem?

Let me know if there is any more information I can give on the problem.

cat /etc/resolvconf/resolv.conf.d/head



lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"SKYC6B48"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 4C:17:EB:AC:6B:49
          Bit Rate=104 Mb/s   Tx-Power=16 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=65/70  Signal level=-45 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:225  Invalid misc:79   Missed beacon:0


lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4538 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4538 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2112909 (2.1 MB)  TX bytes:2112909 (2.1 MB)

wlan0     Link encap:Ethernet  HWaddr 84:4b:f5:74:ee:bf
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::864b:f5ff:fe74:eebf/64 Scope:Link
          RX packets:2383573 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1407209 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2845276498 (2.8 GB)  TX bytes:234741693 (234.7 MB)

sudo lshw -class network:

     description: Wireless interface
     product: AR9462 Wireless Network Adapter
     vendor: Atheros Communications Inc.
     physical id: 0
     bus info: pci@0000:02:00.0
     logical name: wlan0
     version: 01
     serial: 84:4b:f5:74:ee:bf
     width: 64 bits
     clock: 33 MHz
     capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
     configuration: broadcast=yes driver=ath9k driverversion=3.5.0-17-generic firmware=N/A ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
     resources: irq:19 memory:c0400000-c047ffff memory:aff00000-aff0ffff
  • The correct way to configure a Quantal or later NetworkManager system to use alternative nameserver addresses is not to put those addresses in /etc/resolvconf/resolv.conf.d/head but to do the following. 1. Open Edit Connections | <connection-name> | Edit... | IPv4 Settings. 2. Set Method to Automatic (DHCP) addresses only. 3. Enter alternative nameserver addresses into the Additional DNS servers field. 4. Click Save... – jdthood Mar 19 '13 at 9:22

Oh, looks like I've just found the solution. So far this seems to have solved it completely. I ran this:

sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

Following the instructions here under Wifi heading:



By the time you can not ping the Internet servers you are still able to ping your router. Therefore there is no problem with your wireless LAN network.

In order to check if it is a DNS issue, just perform a name resolution for some server on the Internet (while having connectivity) and save both domain name and IP address. Next time the problem is happening then try to ping the server both using its IP address and its domain name.

If ping to server name is not working but ping to its IP address is working fine, then it is a DNS issue and we have to run more checks on your Ubuntu system. If none of the pings is working (and still able to ping your router) then the problem lays between your router and the ISP.

Please run the test and let us know the results

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.