59

How do I prevent Skype from automatically starting every time I boot my Xubuntu 12.10 netbook?

Things I've tried:

  • Removing it from the Settings Manager->Session and Startup->Application Autostart - couldn't find it in the list.
  • Checking for a relevant setting in Skype itself - couldn't find anything of the sort.
  • Using BUM to turn it off - again, couldn't find it in the list.
  • Uninstalling Skype with apt-get remove skype --purge and hoping that it removes all the settings as well - it didn't.

Save for reinstalling, what else can I try?

While on the same note - how is it possible for Skype to autostart without going through the normal Upstart route?

EDIT: Couple of more things I tried:

  • Looking for anything similar in Skype support - I didn't expect to find anything, and I didn't.
  • Looking through the .Skype folder in my home directory. I did find a couple of files which looked promising (.Skype/shared.xml, .Skype/[my username]/config.xml, .Skype/[girlfriend's username]/config.xml), but looking through them didn't yield anything. Plenty of SQLite files though. Could it be that this setting is somewhere within?
4
  • Try going to /etc/xdg/autostart see if an entry for Skype is there, if it is then delete it.
    – Mitch
    Mar 17, 2013 at 11:22
  • Can't see it there.
    – Andrey
    Mar 17, 2013 at 11:26
  • 4
    The solution for 2018+ version is this.
    – user47206
    Mar 7, 2018 at 7:07
  • The solution for snap installed Skype app in the year 2021 should be the answer by @QkiZ. Also see my comment there.
    – Sun Bear
    Aug 5, 2021 at 15:39

17 Answers 17

53

For the new 2017 version of skype that's impudent enough to add itself to autostart each time it's started (seriously? Never installing it on my own machine) it's enough to create a folder with the same name as a file it's trying to create:

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop
12
  • 13
    It also worked for me to open the skypeforlinux.desktop file and (re-)save it with X-GNOME-Autostart-enabled set to false. I.e., X-GNOME-Autostart-enabled=false
    – Tom
    Jan 7, 2018 at 16:10
  • 1
    rm: cannot remove '/home/cip/.config/autostart/skypeforlinux.desktop': No such file or directory
    – user47206
    Mar 6, 2018 at 23:24
  • @Tom - what about KDE? I do not have the line ` X-GNOME-Autostart-enabled`
    – user47206
    Mar 6, 2018 at 23:24
  • Logging in and un-checking the option to start with the system stops Skype from adding itself to autostart each time it's started
    – user47206
    Mar 6, 2018 at 23:31
  • Thanks, @cipricus, maybe there was no such option at the time of writing. Cannot verify it now. Does changing this option change the skypeforlinux.desktop contents?
    – int_ua
    Mar 7, 2018 at 0:49
50

Since it seems the answers here change all the time, as of an install of skypeforlinux from earlier this week (version 8.11.0.4), I managed to get the autostart to cease with two steps.

First, open up Skype, go to Tools > Settings and uncheck "Automatically start Skype".

enter image description here

Then, inspired by azeam's suggestion, go to (Xubuntu) Settings > Sessions and Startup > Application Autostart, and remove the item for Skype. I'm not sure if unchecking works; I tried that first, but it may have conflicted with Skype's internal settings when I tried it.

6
  • 4
    The first step should be enough (and it is, at least in Ubuntu 16.04 with Plasma 5.8) as the setting in Skype is (should be) editing the autostart list .
    – user47206
    Mar 7, 2018 at 7:11
  • 3
    The 1st step is enough. Checked for Linux Mint 18.3 Cinnamon 64-bit, version 3.6.6. and Skype version 8.20.0.9.
    – Alex.K.
    Apr 29, 2018 at 16:24
  • 4
    Note that you must be logged in to Access the "Setting" menu. I have no idea how you could deactivate that auto-start without having an account on Skype. That's crazy.
    – Clément
    May 29, 2018 at 14:19
  • 1
    First step is enough, tested on Skype 8.46.0.60 on Ubuntu 18.04.1 (Xubuntu). Note that you can't get to the settings without signing in to Skype, so I can see how the settings will follow a user from one computer to another.
    – jonathanjo
    Jun 20, 2019 at 9:25
  • 2
    For Skype 8.68.0.100, this option is under the "general" tab of the settings window.
    – dremodaris
    Feb 17, 2021 at 12:05
37

Had the same problem and the following seems to have taken care of it: go to (Xubuntu) Settings > Sessions and Startup > Session, find Skype and left click where it says "If Running" and change it to "Never".

5
  • 1
    Didn't do the trick for me, I'm afraid.
    – Andrey
    Mar 19, 2013 at 19:18
  • 1
    Try to click "Clear saved sessions" under the same settings and make sure the "Automatically save session on logout" is unticked under "General".
    – azeam
    Mar 19, 2013 at 20:43
  • Ah! Unticking "Automatically save session on logout" was something I tried previously, but I didn't spot the "Clear saved sessions" button. It worked, thanks for your help.
    – Andrey
    Mar 21, 2013 at 0:35
  • 4
    For the 2017+ version see other answers.
    – int_ua
    Nov 16, 2017 at 12:51
  • 1
    almost worked for me, the menu changed a little bit... just did tools>settings...> general Jul 6, 2019 at 11:51
10

I had this same issue. I was able to prevent it from starting automatically by removing skypeforlinux.desktop from ~/.config/autostart/. I'm using lubuntu; the location of your autostart folder may vary. You can find by using:

$ locate skypeforlinux.desktop

You'll really only want to delete the copy in the directory called autostart, otherwise you won't be able to start the app from the icon.

I'm assuming that the next time you actually, intentionally run Skype (I hope, for the sake of your sanity, that this day is far in the future) that it will try to put that file back. In which case you might have to delete it again or scour Skype for the setting that will prevent that behavior.

1
  • In my case the application was in /home/user/snap/skype/176/.config/autostart/skypeforlinux.desktop directory. I removed it, and Skype created another one in ...skype/177/.config... . Skype has the option to disable running in the background, for now I will use that option, or maybe I can uninstall it.
    – Sahin
    Jul 14, 2021 at 21:11
6

Go to Tools -> Options -> General settings. Uncheck the option "Start Skype when I start". Save and Quit Skype.

4
  • Not from the client I'm using: imgur.com/EsiEKIl
    – Andrey
    Mar 17, 2013 at 11:30
  • Well, it doesn't work because the option is there, but not in that tools column. Go to Privacy.
    – horIzoN
    Mar 17, 2013 at 12:38
  • @nerof61 As I mentioned in my question above, I've checked the options already. There isn't a single setting that'll let me prevent Skype from starting at boot.
    – Andrey
    Mar 17, 2013 at 15:48
  • That's only in Microsoft Windows.
    – John Scott
    Aug 16, 2014 at 3:34
5

All of these answers didn't work for me because I have installed Skype by Snap. I needed to delete .desktop file from ~/snap/skype/current/.config/autostart/. After relogin Skype stops starting automatically.

1
  • Instead of deleting the file, I simply renamed it from skypeforlinux.desktop to skypeforlinux.desktop.bak. Thank you for your answer. From it, I learnt that each snap app has it own autostart config file that can be deactivated. The autostart config path used to configure .deb pkgs is not applicable. This answer should be the answer of this question in the year 2021.
    – Sun Bear
    Aug 5, 2021 at 15:35
2

In Kubuntu 14.04, the problem was solved by going to Startup and Shutdown, then Session Management and checking Start with an empty session and Apply.

1
  • It was before skype started adding itself to autostart each time you run it. I'm on KDE and it doesn't work. For 2017+ version check other answers.
    – int_ua
    Nov 16, 2017 at 13:07
2

Skype (for Linux) Settings

Open Skype - Menue: extras -> settings -> category: start and close

1. Skype automatic start

switch setting:

true:

/home/$USER/.config/autostart/skypeforlinux.desktop

=>file exist

false:

/home/$USER/.config/autostart/skypeforlinux.desktop

=> file does NOT exist!

rm -rf /home/$USER/.config/autostart/skypeforlinux.desktop

Deletes autostart, but this file is created after changes again!

So it is better to change the code than deleting this file:

/home/$USER/.config/autostart/skypeforlinux.desktop

Autostart: X-GNOME-Autostart-enabled=true

NO Autostart: X-GNOME-Autostart-enabled=false

sed -i 's/X-GNOME-Autostart-enabled=true/X-GNOME-Autostart-enabled=false/g' $HOME/.config/autostart/skypeforlinux.desktop

2. Skype start in background

true:

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized":true

false:

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized":false

3. Skype run in background

true:

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning":true

false:

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning":false

Tested with:

  • skypeforlinux 8.18.0.6 amd64
  • Ubuntu 16.04.1 LTS
  • Cinnamon
1
  • You can't open settings if you didn't sign in, which requires an account
    – Dani_l
    Dec 18, 2019 at 9:21
2

For regular Ubuntu 16.04, search "Startup Applications". When the window opens, just remove the tick from Skype to prevent it starting at boot, then click remove while you selected Skype to clear it from the list.

0

Closing Skype is not the same as Quitting Skype. I did three things in Kubuntu 14.04. After Opening Skype I went to Skype(Menu)>Options>General and checked "Start Skype Minimised in System Tray". Then Options>Advanced and unchecked "Check for updates on Startup". Finally, rather than "Sign out" I clicked "Quit" at the bottom of the menu. I believe that it was the final step that did the trick.

0

Just use GNOME Tweaks. Find Startup Applications. Find Skype and remove. That's all.

0

The solution above is not enough any more. Both skype and teams take the liberty to add themselves to the autostart category on every start - not just at installation. There is a simple counteraction:

cd ~/.config/autostart
rm skypeforlinux.desktion
mkdir skypeforlinux.desktop
chmod 755 skypeforlinux.desktop

Now skype can't do this any more. The same can be used for teams.desktop.

0

TL;DR: Insert "app.autoStartEnabled":false into ~.config/skypeforlinux/settings.json

Since the "Skype" package continuously changes, here is what works as of 2021-01-08 for users who cannot/do not want to log in to open the Settings page.

As others have pointed out, you can use various means to stop Skype from creating/overwriting the autostart desktop file (~/.config/autostart/skypeforlinux) every time it starts again. If you think that's too hacky and want a "proper", hopefully future-proof way, here goes.

Werner Nöbauer points out above that ~.config/skypeforlinux/settings.json contains the user preferences in json form.

However, neither app.onCloseKeepRunning nor app.launchMinimized are what you want to change, it's app.autoStartEnabled, as can be discovered using a bit of de-obfuscation magic:

/* main.js */
t.SettingsKeys = {
    AutoStartEnabled: "app.autoStartEnabled",
[...]
0

In my case (Ubuntu 20.04) Skype was install via a snap. So the file to remove was:

/var/lib/snapd/desktop/applications/skype_skypeforlinux.desktop

As I'm not using it and I'm annoyed by this automatic start that I didn't ask for, I also uninstalled by running:

sudo snap remove skype

0

Prevent skypee startup at start time in ubuntu.

Login skypee and in menu items.

In Skypee Menu -> Tools-> Settings -> General -> Automatically start skypee.

enter image description here

0

There are Three simple steps to disable skype from starting on screen or automatically on booting in ubuntu.

Step1: Open skype and click on three dots(...)appearing on top menu bar then click on setting option.

Step2: Then click on >>General setting option.

Step3: Where you will find option >>Automatically start Skype option disable it if it is enabled.

New contributor
Kartik M Prajapati is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
-1

It seems to be the case that 'closing' Skype isn't actually really closing it. You can notice that also by the fact that if you 'reopen' it, it is already logged in.

You can really close it by typing in the command line:

killall skype

This way it won't be saved in your working session when you log out of your computer, and so won't be automatically restored when restarting your computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.