8

I have a Canon 40D that worked well with 32-bit Ubuntu all the way from 10.04 through 12.04. However, I switched to 64-bit 12.04 a while back, and since then, connecting the camera just brings up a simple dialog:

Unable to mount Canon Digital Camera
Error initializing camera: -1: Unspecified error

This problem persists in 12.10 and the latest 13.04 build.

syslog doesn't say much other than

kernel: [12089.871412] usb 3-1: new high-speed USB device number 3 using xhci_hcd
mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
mtp-probe: bus: 3, device: 3 was not an MTP device
kernel: [12453.142322] usb 3-1: USB disconnect, device number 3

I've seen some random bugs on launchpad about this, but nothing that directly pertains to it. This seems like such a glaring problem that I figure I'm doing something wrong on my end. What's the proper way to get a camera to work on 64-bit Ubuntu?

  • Btw, found a bug about the Rhythmbox MTP plug-in interfering. But I don't have this plug-in installed, so that's not it. – EboMike Mar 17 '13 at 10:24
  • Actually, it suspiciously looks like this: bugs.launchpad.net/ubuntu/+source/gimp/+bug/1094888 . Are there any known work-arounds? – EboMike Mar 17 '13 at 10:42
  • 1
    Is there a setting on the camera that you can select that specifies what happens when it is connected to a PC? i.e. on a Nikon D70 you can select 'usb mass storage' mode, so that when you connect it to the computer it will be recognised not as a camera, but just as a flash drive. This works on Ubuntu 12.04 with a Nikon D70, although your problem may be 64 bit specific. The other option is to use a USB card reader. – user76204 Mar 17 '13 at 13:37
  • @Mik Nope, the 40D doesn't have a mass storage mode as far as I can tell. My current solution is to run Windows in VirtualBox, connect the camera there and then copy the pictures back to my Ubuntu host when I'm done, but that's obviously not optimal. And the 40D uses CF cards - I have a gazillion SD readers, but I don't feel like buying a CF reader to work around a bug that will eventually be fixed. – EboMike Mar 18 '13 at 6:35
6

I have the same issue on Ubuntu 12.10 (64-bit) with a Canon EOS 400D. I found reports about this only happening when connecting the camera through a USB3.0 port, but not when plugging in the cable to a USB2.0 port; however, this workaround is not working for me with an Asus N76VM laptop. Maybe it works for you.

  • This workaround works for me on a Lenovo x131e, running 64 bit, 12.10. Cannon 400D works on USB 2 but not USB 3. – MorrisseyJ Apr 3 '13 at 21:20
  • Thanks a LOT for that.This was exactly my issue. Switching ports fixed it :) – Nicolas de Fontenay Aug 31 '13 at 2:54
  • Doesn't work for me - tried all three ports, same problem on each one. – EboMike Oct 1 '13 at 11:33
  • One workaround is to use a card reader instead of trying to connect the camera. I bought one for less then 5 euro. – Stefan Oct 10 '13 at 10:46
4

A workaround that worked for me was killing both gvfs-gphoto2-volume-monitor and gvfs-mtp-volume-monitor. I killed the gphoto2-one first, so I don't know if it was necessary or if just killing the mtp-one would have worked.

  • It was gvfs-gphoto2-volume-monitor! But the damn thing keeps coming back - I made it non-executable to fix it for good. Works now! – EboMike Oct 17 '13 at 5:06
2

Blizzara's answer led me to a proper solution - gvfs-gphoto2-volume-monitor is interfering. I tried killing it, but it's keeps coming back.

So I took the sledgehammer and whacked it right upside the head like this:

sudo chmod 644 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor 

And that did it! (Of course, I did have to do a ps ax | grep gvfs-gphoto once and kill the already-running process.) Shotwell now downloads my pictures like a charm! I'm sure there's a better solution to this problem, not to mention that we shouldn't be having this problem in the first place, but I'll take this for now.

Btw, since Blizzara led me to this, B's answer deserves an upvote.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.