I have a fresh installation of Ubuntu 12.10.When I tried to install nvidia drivers the following errors occurred. Please help. Can I use Nvidia drivers with Unity?

khat33b@Oa:~$ sudo apt-get install nvidia-current-updates
[sudo] password for khat33b: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/67.7 MB of archives.
After this operation, 204 MB of additional disk space will be used.
Selecting previously unselected package nvidia-current-updates.
(Reading database ... 155992 files and directories currently installed.)
Unpacking nvidia-current-updates (from .../nvidia-current-updates_304.51-0ubuntu1_amd64.deb) ...
Processing triggers for man-db ...
Setting up nvidia-current-updates (304.51-0ubuntu1) ...
update-alternatives: using /usr/lib/nvidia-current-updates/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-alternatives: using /usr/lib/nvidia-current-updates/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-current-updates
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Processing quirk ThinkPad T420s
DEBUG:Failure to match Dell Inc. with LENOVO
DEBUG:Quirk doesn't match
DEBUG:Processing quirk Latitude E6530
DEBUG:Failure to match Inspiron N5110 with Latitude E6530
DEBUG:Quirk doesn't match
Loading new nvidia-current-updates-304.51 DKMS files...
Building only for 3.5.0-17-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-17-generic

I have Dell Inspiron N5110, RAM 3.8GB, Processor Intel® Core™ i5-2430M CPU @ 2.40GHz × 4, Graphics is shown Unknown, 64bit OS.

The result of lspci |grep VGA is:

khat33b@Oa:~$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)

Also, Ubuntu has experienced an internal error window keeps on popping up. On clicking show details, The executable path is /usr/share/apport/apport-gpu-error-intel.py. There are also many other details.It's a pretty huge list!

Another window also appears: Apport has detected a possible GPU hang. Did your system recently lock up and/or require a hard reboot?

  • what is your hardware? please edit your question and put result of lspci |grep VGA
    – Web-E
    Mar 17 '13 at 4:53
  • This question is 6 years old. Are you sure you don't want to delete it? Jul 6 '19 at 23:10

Have you tried this nvidia-section at ubuntu.com?


I believe it would help you solve most problems with nvidia-cards in an ubuntu environment.

  • This will not work as I have an Nvidia Optimus card. I tried installing bumblebee but nvidia does not show in dash; from the terminal nvidia shows installed
    – khateeb
    Mar 26 '13 at 0:55
  • oh ok. It appears that there are problems with Optimus cards. There are several posts about it scattered around. I dont know if it can be solved or will be solved in the near future. But I found this interesting list at nVidias own site: download.nvidia.com/XFree86/Linux-x86/310.19/README/… It lists supported cards in a Linuxx86 environment. It would always be a good idea to check compatibility before buying. This holds true especially with graphic cards. Mar 27 '13 at 13:02
  • What happens if you run "optirun glxspheres" in terminal? Maybe it works..
    – aXept
    May 7 '13 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.