5

I am facing a problem with display brightness in Ubuntu or other versions of Linux. Running a Linux distro as live or HDD installation or inside the installation, display brightness is automatically set to the highest value, I'm unable to decrease it, this is an annoying problem at night.

I have tried about 25 different Linux Distros in my laptop another 3 laptops of friends but the same problem, no problem with the desktop as the monitor has its own brightness control switch.

My laptop is Acer 5830TG, i5 2410M @ 2.3 GHz, ram-3gb, HDD-640gb @5400 rpm, NVIDIA GT540M, chipset-Intel HM65. OEM os- windows7 Home Premium.

I have tried the Fn+< (left arrow key) as in windows, Ubuntu is showing that brightness is decreased but not really, display brightness is same.
Also tried Ubuntu display brightness applet.

And at Terminal~$ sudo setpci -s 00:02.0 F4.B=** where ** is two digit hex value, 00:02.0 is internal display adapters(Intel HD 3000) hardware address(lspci | grep VGA).

Nothing happened, display brightness remained the same.

4

Try below,

execute gksu gedit /etc/default/grub

Change this line

GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

to something like below

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Execute sudo update-grub and reboot . See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.


This is for setting brightness manually after doing the above steps.

Try following for paths shown by ls /sys/class/backlight/*/brightness and replace accordingly.

example paths will be like

/sys/class/backlight/acpi_video0/brightness
  1. For the above path Get the maximum brightness:

cat /sys/class/backlight/acpi_video0/max_brightness

Try a lower value to set the brightness, say output is 16 so I will try with half of it

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If this works, make this happen in each login automatically by doing the following

sudo gedit /etc/rc.local

Enter this line just before exit 0. It should look like

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0
0
sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf
sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

insert next text:

Section "Device"
   Identifier "card0"
   Driver "intel"
   Option "Backlight" "intel_backlight"
   BusID "PCI:0:2:0"

EndSection

save, and reboot.
After reboot Fn + arrow key should work

  • I was using this trick in 13.10 and 14.04. I don't need it anymore in 14.10 with intel hd 4000 – solsTiCe Dec 12 '14 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.