I have an ATI 5670 HD. I'm running ubuntu 12.10 64bit. I've been having a hell of a time trying to install the most recent drivers for my video card. Everything else seems to be working with the exception of the video card. It's a fresh install on a new partition.

I followed the instructions to the letter here: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide

And my card is definitely supported by the drivers, I know this for certain because in another partition I have a 32 bit system where both Catalyst 13.1 and 13.2 work flawlessly:

sudo lshw -C video
PCI (sysfs)  

  *-display UNCLAIMED     
       description: VGA compatible controller
       product: Redwood [Radeon HD 5670]
       vendor: Advanced Micro Devices [AMD] nee ATI
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:fbee0000-fbefffff ioport:e000(size=256) memory:fbec0000-fbedffff

Then I tried using this tool (which essentially duplicates the instructions on the guide): http://www.thefanclub.co.za/how-to/ubuntu-amd-catalyst-install

What I end up with is always the same, regardless of which drivers (13.1,13.2) I install on the system.

$ fglrxinfo 
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

I've tracked what I believe to be the problem during the manual install process:

(Reading database ... 198845 files and directories currently installed.)
Preparing to replace fglrx 2:9.000-0ubuntu3 (using fglrx_12.100-0ubuntu1_amd64.deb) ...
Removing all DKMS Modules
Unpacking replacement fglrx ...
Preparing to replace fglrx-amdcccle 2:8.970-0ubuntu1 (using fglrx-amdcccle_12.100-0ubuntu1_amd64.deb) ...
Unpacking replacement fglrx-amdcccle ...
Preparing to replace fglrx-dev 2:8.970-0ubuntu1 (using fglrx-dev_12.100-0ubuntu1_amd64.deb) ...
Unpacking replacement fglrx-dev ...
Setting up fglrx (2:12.100-0ubuntu1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
update-initramfs: deferring update (trigger activated)
Loading new fglrx-12.100 DKMS files...
Building only for 3.5.0-17-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up fglrx-amdcccle (2:12.100-0ubuntu1) ...
Setting up fglrx-dev (2:12.100-0ubuntu1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-17-generic
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

The part where is says "update alternative" does not present itself during the duplicated installation process on my 32bit Ubuntu install on the same computer:

update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

I was able to get it up and running by repeating the initial process (either the app from fan club or the instructions on the page above):

sudo apt-get install linux-source
sudo apt-get install linux-headers-generic
sudo apt-get install linux-headers-$(uname -r)

I'm not sure which of the three was the one that "did" it, but after they were installed I was able to successfully go through the process.

  • Confirmed, worked for me; 12.10 64-bit, ASRock motherboard, AMD processor, 7950 card. Did have to restart though. – Will Apr 11 '13 at 5:31
  • This worked for me as well. I already had the linux-headers-* installed, but not the source. – CB750 Rider Feb 25 '16 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.