I am trying to install electrum on my Ubuntu live USB. Please forgive me because I am very new to this OS. I have also made a persistence 4GB space for installing software.

How can I get past this error? I tried using

sudo apt-get update

first, but I still get

E: Unable to locate package python-pip

when I try to install.


2 Answers 2


Two Methods:

  • You can install through Ubuntu Software Center.

    1. Open Ubuntu Software Center and search for easy_install

    2. Highlight alternative Python package installer (python-pip) from the list and click Install

    3. You can check weather the installation was successful or not by giving the command

      which pip

      you will see the path of installed application, for example


  • Second method

    1. Open terminal by pressing CTRL+ALT+T and type the following:

      cd ~

      to navigate to your home directory.

    2. Then issue the below command:

      wget -P Downloads/ https://svn.apache.org/repos/asf/oodt/tools/oodtsite.publisher/trunk/distribute_setup.py

    3. Next step is to run the downloaded script. To do this, issue this command:

      sudo python Downloads/distribute_setup.py

    4. and type your user password when prompted (Please, note that your account needs to be a member of Administrators group in order to issue sudo).

    5. Hit Enter and let the script run.

    6. To ensure easy_install is installed, issue the command below:

      which easy_install

      The typical response in case the installation completed successfully would look something like this:


    7. The next thing to do is use easy_install to install pip. For that you’ll need to issue:

      sudo easy_install pip

    8. Enter your password if prompted to confirm command.

    9. Let the installer run and once the installation is completed type:

      which pip

      This command should typically respond with something like this:


  • 1
    Hello I tried typing 'easy_install' but no result returned :(
    – Squid34
    Mar 16, 2013 at 15:25
  • I also tried searching the exact words alternative python and python-pip also doesn't return any result.
    – Squid34
    Mar 16, 2013 at 15:28
  • It says "Interactive high-level object-oriented language (default version)" is installed
    – Squid34
    Mar 16, 2013 at 15:30
  • python interpreter 2.7 and 3.2 also installed
    – Squid34
    Mar 16, 2013 at 15:31
  • I mean they have check marks on the icons
    – Squid34
    Mar 16, 2013 at 15:32

I, too, am new to Ubuntu, and I had a similar problem. I needed to install pip, but kept getting the error message:

Unable to locate package python-pip

After doing more research, I tried:

sudo apt-get update
sudo apt-get install python3-pip

This seemed to do the trick for me. I hope this helps others having the same issue.

Not the answer you're looking for? Browse other questions tagged .