I had Linux 12.10 on my hard drive and after much frustration trying to get certain Windows programs to work with it, I reinstalled Windows on a new hard drive (in case I wanted to go back to Linux).

After awhile, I got an external-drive-converter-thingy and booted Linux from it. It worked fine. Then when I tried again without changing any settings 2 hours later, I got the grub rescue error. I have no idea why it should be any different since no settings have changed.

I want to format the drive to use as an external drive, but Windows doesn't recognize the file system either, and won't let me access it. (It's weird. Windows registers it as being plugged in - it lets me safely remove it - but it doesn't register it as being a drive in My computer. I have Windows XP if that helps.)

How can I access the contents of the drive/format it?


I had grub error two days ago as well !! https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu

I used this and it worked for me and I think it will work for you as well

If you for some reason windows does not show on the grub menu, use this

sudo update-grub

I did when I had the problem two days ago.

  • BTW I used live USB to do that. – za3bolla Mar 15 '13 at 22:09
  • If you just want to access the ext2/3/4 drive from windows there are many disk managers that can do it. howtoforge.com/access-linux-partitions-from-windows – za3bolla Mar 15 '13 at 22:16
  • When I type in any common command like sudo it tells me unrecognized command. – Weboh Mar 15 '13 at 22:45
  • Copy and paste the commands, do not write them yourself. – za3bolla Mar 16 '13 at 6:28

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.