0

I'm using Ubuntu 12.10 (Quantal Quetzal) and Zend Server CE 5.6. For some reason I want to try XAMPP, but Zend Server CE automatically start every time I boot up my laptop. Is there a way to stop it?

I don't want to uninstall Zend Server CE.

1

Zend Server CE installs a run script in /etc/init.d/zend-server (which is in fact a symlink to /usr/local/zend/bin/zendctl.sh). The easiest way how to stop Zend Server CE from starting is to remove the symlink, e.g.:

rm /etc/init.d/zend-server

That way the original file will be kept on your system, but it will not run at startup.

[Edit]: If you want the service back just symlink it back:

ln -s /usr/local/zend/bin/zendctl.sh /etc/init.d/zend-server
-1

You can do it with bum.

Type sudo apt-get install bum, then launch it with sudo bum.

  • 1
    I don't think you need whole graphical runlevel editor with a bunch of dependencies (GTK+ ) just to disable one service. The user doesn't have to run XServer on the server machine. – oerdnj Mar 18 '13 at 15:54
-1

This is happening because the OS is starting the default HTTP service when it boots. Zend Server has a dependency on the Linux httpd service when it installs. So you'll have to configure httpd to not start automatically and start it manually when you want.

  • I am sorry, but this doesn't make any sense. Zend Server CE (or Zend Server Free) does install it's own init.d script, which starts couple of things. You are throwing out the baby with the bath water by disabling HTTPD daemon. – oerdnj Mar 18 '13 at 15:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.