I have replaced my external hard drive and now need to do a full backup of my home directory onto the new drive.

I've change the location in Deja Dup and it creates the new directory fine, but the backup is done in seconds. There's no way it backed up all the data in that time!. So I assume it thinks the old drive is being retained and doing an incremental backup onto the new one. How do I convince it to forget everything and start fresh with a complete backup on the new drive?

I've tried sudo apt-get purge deja-dup

And I've tried deleting ~/.cache/deja-dup

Neither forced Deja Dup to forget its settings.

I'm using Ubuntu 12.04

Home directory is encrypted and external the new hard drive is encrypted.

Also used dconf editor to set deja-dup back to defaults in >org>gnome>deja-dup, but still no luck.


  • Ok, so it seems to backup folders outside of my home directory (I tried using the /tmp directory as a test). But it won't backup my home directory, or any directories within it. It insists it has but restoring to a new folder gives me an empty folder. – Mattarn Mar 16 '13 at 20:09
  • As said above, my home directory is encrypted. Is this the problem? Permissions maybe? – Mattarn Mar 16 '13 at 20:12

So it looks like it was a permission issue in the end. I was having similar problems with EasyTAG and other MP3 tag editors: MP3 Tag editing with an encrypted home directory

This fixed my issue:

sudo chmod o+r /home
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.