I kept my music library, about 9000 songs, safe on Google Play Music while I was without a personal computer. Now I've got a laptop running 12.10. I've installed Google Music Manager beta and want to use it to download my entire library.

Here's the problem:

Music Manager starts downloading and goes for a while. Although the status bar never moves, and it still says "0 of 9000 songs downloaded", my music folder shows that I've successfully downloaded about 1500 songs. However, Music Manager is now undoubtedly not downloading anything and I can't seem to start it up again.

I know that if I go into my .config folder and delete the Google Music Manager folder from there, next time I start the Music Manager, it'll start over from the beginning and actually start downloading again, but there's no point in doing this if I have to start over each time and won't make it to the end anyway.

Any help, please?

  • where you ever able to figure this out? I have a problem where the upload seems to stop as well. The Google Music Manager app disappears from my systray – jjesse Apr 4 '13 at 13:03
  • I actually installed Windows 8, downloaded the music, copied to a hard drive, and reinstalled ubuntu. Maybe Wine could do that, i don't know, i don't drink – ike368 Apr 22 '13 at 20:10
  • This seems to be a connectivity issue, are you using wifi or ethernet cable to connect to the internet? – Shayan May 24 '19 at 23:33

I've had this behaviour on a Windows 7 machine, in the Download tab cancel the download, then close music manager (or reboot your machine). Start up Music Manager again, go back to the download tab and start the download again to the same folder. It seems to start up again where is left off.

Note that I had previously tried just closing and starting Music Manager without cancelling the download and it made no difference, same with a reboot. Also cancelling and starting the download without restarting Music Manager in between also did nothing. Only cancelling, recycling Music Manager then restarting the download seemed to work.

This may not work in Ubuntu, but it's worth a shot.


I had the same problem but found a solution that worked for me.

Go to the Upload tab and delete the folders.

That's it. The download restarted immediately continuing from where it had stopped.

I hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.