My short question is:

How do I get rid of the RandR error below, while still using a proprietaty nVidia driver package (e.g. 304) ?

The gore follows.

A fresh install of wine 1.5 (latest, from ubuntu-wine ppa) leaves me with the following when I run winecfg for the spanking-first time, and note I have not touched winetricks yet, nor does ~/.wine exist :

me@mine:~$ winecfg
wine: created the configuration directory '/home/me/.wine'
**err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.**
[err repeats at least 4x more]
fixme:storage:create_storagefile Storage share mode not implemented.
[fixme repeats at least 2x more]
err:mscoree:LoadLibraryShim error reading registry key for installroot
fixme:storage:create_storagefile Storage share mode not implemented.
fixme:iphlpapi:NotifyAddrChange (Handle 0x112e8d0, overlapped 0x112e8dc): stub
wine: configuration in '/home/me/.wine' has been updated.
**err:winediag:xrandr12_init_modes Broken NVIDIA RandR detected, falling back to RandR 1.0. Please consider using the Nouveau driver instead.**
[err repeats sporadically]

Removing the current nVidia packages and (re)installing Nouveau gets rid of the RandR error, but gives me copious errors when I launch anything requiring shader model 3, e.g. Eve Online, my only motivation to wrestle with Wine, currently. For it to run, I know I need the proprietary driver, and so Nouveau is not a solution for me - unless y'all know how to get sm3 support with the open stuff currently available, which would be just fabulous and tell me please.

I have gathered from WineHQ that the fixmes and the majority of errs are an innocuous "don't look behind the curtain" type of wish-list verbosity.

This Broken nVidia RandR thing, though, is something I'd like to deal with in order to get to, well, the other graphics issues I'm crossing my fingers about (in particular, a manual modification of wine1.5's shader model 3 detection routine to allow for my nVidia GeForce Go 7900 GS, which is one of the few sm3-compliant laptop gpu's to come out before sm4-type features were also implemented, leaving it out of consideration by the current Wine developers who seem to use sm4-ish flags to test for sm3 suport).

In order to tinker with my other woes, I must first eliminate the non-starters. This RandR is one. I think it's different from the other related posts in that I have not attempted to run anything other than winecfg itself to elicit the error, as opposed to a third party program.

PS `uname -a` --> Linux aestrid 3.8.0-12-generic #21-Ubuntu SMP Thu Mar 7 17:17:00 UTC 2013 i686 i686 i686 GNU/Linux

PPS `raring` up-to-the-minute update/dist-upgrade

How to solve this ?

PPPS If Henri Verbeet is listening.

  • Same problem here with a GeForce 320m – nbm Jan 28 '14 at 0:27
  • 1
    @nbm - just meant as idea or suggestion - deinstall wine, avoid dual-boot with win-x - test this nvidia-driver (but remove all drivers you have tried out before)...askubuntu.com/questions/311151/… – dschinn1001 Jun 5 '14 at 4:20
  • Do you still have this problem? – Elder Geek Apr 7 '15 at 15:51

Install winetricks and run winetricks orm=backbuffer glsl=disable. This will fix the error mentioned.

| improve this answer | |
  • in case you cannot live without wine, not without samba, and not without windows, then this option with winetricks is then probably creating less trouble, but only to your desktopand not to mine or not to those, who want to live without dual-boot like in this situation and therefore am then one of those Linuxers who are less touchable ... :o) ... – dschinn1001 May 3 '15 at 17:25
  • @dschinn1001: I agree, but the user asked something wine-related. ;) – Frantique May 4 '15 at 6:54
  • 1
    + is ok + users should know this too + more ubuntu-related installation and less wine-windows-samba-installation is making hardware living longer ... + ... :oD – dschinn1001 May 4 '15 at 7:40
  • 4
    This one liner has no effect on the RandR warnings on my system. – James K Oct 24 '15 at 7:45
  • 1
    Did not work for me. – Organic Marble Sep 19 '19 at 14:52

Maybe I'm moving far from the solution here, but if you did your own installation with the script provided by nvidia, I would try to add ppa of xorg-edgers, update and install the driver prepared by them:

sudo add-apt-repository ppa:xorg-edgers/ppa

It saved me lots of troubles when trying to install official nvidia drivers in the past and since then I had no troubles at all with wine or anything.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.