I have created a restricted user which logs in automatically and Chromium runs the default home page with the screen starting maximized but I want it to run in fullscreen (F11) mode. I tried kiosk mode but I don't want to be that restricted and it doesn't seem to behave properly at all (keyboard is almost broken).

I would consider digital signage software but don't really want anything client/server. I just want the machine to boot straight into fullscreen mode. Does this work for firefox?


3 Answers 3


For people finding this now, you can start Chromium fullscreen from the command line by executing:

chromium-browser --app=http://example.com --start-fullscreen

Tested on Ubuntu 14.04 LTS

  • 3
    better than the default answer
    – ligi
    Jan 29, 2016 at 17:49
  • 6
    better than my answer from 2013, which was the only solution because the -start-fullscreen was not present in chromium browser as I remember.
    – Dee
    Feb 25, 2016 at 8:55
  • 1
    can confirm that this still works (tested with Chromium 65.0.3325.181), although it is still not listed in the chromium-browser man page (after 3+ years)
    – patpir
    Mar 3, 2019 at 18:33
  • 2
    Still works, here in 2020.
    – Brad
    Mar 19, 2020 at 5:37

What about using xdtool http://manpages.ubuntu.com/manpages/lucid/man1/xdotool.1.html

xdotool key F11

this will work for any kind of standard focused window. Include it into start-up script.

don't have xdotool?

sudo apt-get install xdotool

in combination with --start-maximized (which does not do F11, just maximized window) on command line can fulfil your needs

shell script should make the job

chromium-browser --start-maximized
sleep 5
xdotool key F11

Firefox differs only in -fullscreen command line option. The option for F11 mode is missing as well. But consider to use Firefox and Rkiosk extension https://addons.mozilla.org/en-US/firefox/addon/r-kiosk/?src=search or the Fullscreen extension https://addons.mozilla.org/en-US/firefox/addon/full-fullscreen/

If the script stucks at chromium-browser invocation - add a & at the end:

chromium-browser --start-maximized &

Based on this and other sources, you could try the following, with good chances of success :-)

cp /usr/share/applications/chromium-browser.desktop ~/.local/share/applications/chromium-browser.desktop
nano ~/.local/share/applications/chromium-browser.desktop 

(you may alternatively want to use gksu and the editor of your choosing)

Now, simply add -start-maximized to the line saying exec in chromium-browser.desktop, save and you're done.

  • Combine with RadicalRaid's answer and change the line to Exec=chromium-browser --start-fullscreen %U, or Exec=chromium-browser --start-fullscreen --app=http://example.com %U. Include --kiosk flag to avoid the message Press F11 to exit full-screen (from here). I like this solution best. Jan 3, 2020 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.