I just had an Ubuntu system of mine completely die on me after upgrading it and now I am confused.

Basically, it is an older machine (Intel P3, 512MB RAM, etc) that I use as a command line only test bed. It's CPU does NOT support PAE extensions. PAE is mandatory when installing 12.04 LTS so what I basically did was install 11.10 x86 and then updated to 12.04 LTS and that worked fine. It even detected the CPU didn't support PAE, ignored the PAE kernels, and updated all the relevant non-PAE packages correctly (including using non PAE kernels under 12.04 LTS).

Fast forward a few months as I hadn't used the thing so I wanted to update it. Did apt-get update and it listed a bunch of packages including a new kernel. At the top, it did saw something along the lines of "these packages are being ignored" and then listed several *PAE packages. So I proceeded with the update as everything it was going to do look OK to me, however, the update failed (see screenshot below) and now the machine won't even boot.


What is going on? Is it not possible to update 12.04 LTS anymore on non-PAE machines? How come it tried to (seemingly) update *PAE packages when my CPU can't support them? I feel like this is the root of the problem but if you have any other idea's or suggestions, please mention them!

1 Answer 1


I would not recommend Ubuntu for a PC with a non PAE core. If you can get it to run performance is unlikely to be satisfactory.

You can however use Lubuntu 12.04 on non PAE systems. Lubuntu is a much lighter desktop than Ubuntu but as you use it mainly from the command line it should be fine for your needs and its supported in this forum.

Download is here


Lubuntu 12.10 requires a PAE however.

If you want to try installing Ubuntu 12.04 on a non PAE system however Take a look here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.