I'm attempting to boot a 64bit Ubuntu 12.10 live USB on a Microsoft Surface Pro.

I do not want to Dual Boot.

I have disabled "secure boot". I have a live USB that can sucsessfully boot on another machine.

When I boot, i can get to the grub menu. However, when I select any of the options, "Try ubuntu without installing" for example, i get a dark screen and the OS doesn't boot. My only option at that point is to power off.

Has anyone else had this issue? I've researched everywhere I can think of. Any ideas what might be wrong?

Thanks for the help.

  • 1
    I appreciate the feedback. However, I do not want to dual boot. I simply want to run the OS off the Live USB. Therefore I do not believe this is a duplicate of "Dual boot Surface Pro with Ubuntu?". If you MUST dual boot I can accept that and move on. However, if it is possible i would like to know how to run off the Live USB. Thanks again for all the help.
    – Matt
    Mar 15, 2013 at 14:18
  • Can you please edit your question and make that really clear? In the mean time I'll try to get this re-opened.
    – Seth
    Mar 15, 2013 at 16:02

3 Answers 3


Aside from all of the obvious things that one can read from the internet about booting from USB on the Surface Pro (i.e. hold down volume button, disable secure boot, etc.), there are a few important things that you need to do to the USB drive before your Surface Pro will boot from it. Why these things are frequently ignored on the "how to boot from USB on your Surface Pro" websites, I don't know. Anyway, here's what you need to know about the media you're trying to boot.

1. The Surface Pro will ONLY boot from disks that are partitioned with a GPT partition scheme AND configured for a UEFI firmware interface. So, if your Surface seems to be ignoring your attempts to boot from USB and going straight into Windows 8, this is likely your problem. Unlike just about every other computer sold today, the Surface has no support for legacy boot. In other words, that USB stick that boots just fine on every other computer in the world (except your Surface) is likely partitioned with an MBR scheme and/or designed for a BIOS firmware interface.

2. The Surface Pro will only boot 64 bit operating systems. In my experience, when trying to boot a 32 bit OS, things will look like they're booting properly for a little while, and then crash, and then boot into Windows 8. Take note, this is different from what happens when it's issue #1 is preventing you from booting from your USB.

3. The Surface Pro will only boot from partitions that are formatted in FAT32 (and possibly FAT16 and FAT12 - I've never tried booting a FAT16 or FAT12 partition and have read conflicting reports as to what is possible with the Surface.) This is a condition of UEFI boot. If you're trying to boot a disk formatted in NTFS, ext3, ext4, etc. it won't work.

Your probably saying to yourself, "Great, now that I know the rules, how to I make my drive conform?". If you have a drive that doesn't meet the above rules, you may or many not even be able to make it conform. I'll let someone else tackle that hurdle.

However, if you have an .iso file that you want to make bootable from your USB, you just need to do the following:

  1. Make sure the .iso file is for a 64 bit OS
  2. Download Rufus (http://rufus.akeo.ie/) and use it to create your bootable USB. Be sure to select "GPT partition scheme for UEFI computer". There may be other programs out there, but Rufus is the only one I've found that sets up the partitioning properly for the Surface.
  3. Make sure secure boot is disabled on your Surface.
  4. Power down the Surface, hold the volume button down and power the Surface up while continuing to hold the volume button down.



I discovered a solution to my particular issue:

The Surface Pro has 3 ways of booting to a USB:

  1. Accessing the "Advanced Startup" menu in Windows 8
  2. Holding SHIFT while booting/re-booting (this takes you to the same place as #1)
  3. Holding the Down Volume button while booting (boots directly to the USB)

The first two options allow me to get to the grub menu but then freeze when I make one of the selections (see my original post above). However, if I power down the device then boot while holding the Volume Down button (on the side of the Surface Pro) I am able to progress past the grub menu and boot successfully to the OS.

So, for anyone interested, my successful process from start to finish was this:

  1. Create a Live USB with Ubuntu 12.10
  2. From a powered-down state, hold UP volume key and power on
  3. In the resulting menu disable Secure Boot and then exit
  4. Power on the device, plug in the USB and then power down
  5. Power on again while holding the Volume Down button and then proceed through boot process

Hope someone finds this useful and thanks again to those who offered help.


Also turn on Legacy Boot if you can. I haven't played with the Surface Pro but have worked on other UEFI boot devices (Dell XPS 12) and been able to get live boot distros to start.

Here is some good info from the Community: https://help.ubuntu.com/community/UEFI

Good luck.

  • Thanks for the advice but I cannot find a Legacy Boot option...
    – Matt
    Mar 15, 2013 at 14:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .