7

How can I run a nested accelerated xserver? I've tried using Xephyr, including using the -fakexa but nothing seems to work. I also tried xnest, but xephyr was intended to be it's replacement and it too doesn't offer acceleration.

For Xephyr, it appears like work was done in the past to have xephyr support acceleration. It seems this work was never mainlined and/or no longer compiles against the current codebase.

http://gitorious.org/xserver-with-gl-accelerated-xephyr/xserver-with-gl-accelerated-xephyr

http://dodji.blogspot.com/2007/10/xephyr-xvideo-and-gl-has-landed.html

Note that although I'm asking about xserver, I would be happy to hear about wayland, mir or whatever else that is capable of running nested with acceleration.

  • What exact acceleration are you referring to? OpenGL, Xv, hardware video decoding, ...? – gertvdijk Mar 19 '13 at 20:37
  • gertvdijk, yes I am wanting opengl acceleration. Preferably done via hardware of course, but software acceleration would also be interesting to me if it worked. – balloons Mar 20 '13 at 21:30
1

There was a bug preventing this from working which has now been fixed. Xephyr works properly using glx under raring, quantal and precise now. See this bug: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1079096

  • So should it just work or do I need special command line arguments when launching Xephyr? – Shelvacu Feb 28 '15 at 23:36
  • 1
    This should just work. Note if you are running closed drivers it might not support opengl acceleration. – balloons Mar 26 '15 at 17:25
  • I have been unable to get this to work, and it may be related to the fact that I'm using the proprietary nvidia drivers. – Scott Jan 25 '17 at 4:02

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.